Processing doesnt open

Description
I used processing like 2 times during lessons and I had no issues, but suddenly during a 3rd lesson i just cant open the file. When I click on the processing icon, or on the project file I get the logo window for a minute or two and then it dissapears and nothing happens.

Expected Behavior
Processing should open.

Current Behavior
It doesnt open.

Steps to Reproduce
I am basically copy and pasting this from another thread because my situation is the same but i didnt find a solution there.

I have tried the following steps:

  1. Delete processing, and download a new one
  2. Download the latest version of java
  3. Run processing as admin
  4. But none of these makes things better.

I even downloaded previous versions of processing but it doesnt work. I saw also this post but it didnt help.
My Environment

Processing version: 3.5.4
Operating System and OS version: Windows 10 Pro
Other information: 64bit

Hi @glithch
Are you sure that when you uninstalled Processing, you also deleted the preference (settings) files?
They normally reside in C:\Users\YourUserName\AppData\Roaming\Processing.
The folder AppData is often not visible. You have to set it visible in de windows file settings.
Then delete the Processing folder.

I did that and it worked but for some reason after turning my computer on and off it wouldnt work again and i had to redo the whole process. Especially irritating since once i open the processing file once and it doesnt open, I have to open and close the computer before I can delete it, because otherwise it says it cant delete the file because its being used…

So am i just supposed to install and uninstall the program everytime I turn off my computer?

Can you post the preferences.txt and also the path to it?
Where do the other Processings folders reside?
Did you deinstall everything(including preferences.txt) and after that reinitiated to re-install?


This is the preference.txt and the path is
C:\Users\Pamela\AppData\Roaming\Processing

I deleted the whole processing folder from the roaming so I think thats everything I could possibly uninstall along with the actual program which is in

H:\processing-3.5.4-windows64\processing-3.5.4

What do you mean by reinitation? I just deleted both the folders and then unpacked the zip again.

Sorry typo! I mean uninstall everything and then restart/reboot the computer, before installing Processing again.
Normally the folder “processing-3.5.4” is placed in the drive that contains Windows (C?) in the folder “Program Files” (On my PC “C:\Program Files\processing-3.5.4”) This folder contains the executable processing.exe com tools etc.
Another folder that contains the Sketchbook you can place where you want, setting it in the IDE menu/preferences dialog.
I saw that yours is saved in “C:\Users\Pamela\Documents\Processing”, meaning that your main Windows drive is ‘C’, so that’s where the executable should be installed. Not in drive ‘H’)

IMO that’s bad advise. The farther Processing is away from the OS system folders the better. :relieved:

The folder %ProgramFiles% is reserved for apps which have an actual installer.

Processing in both Windows & Linux versions is merely a compressed folder.

Why bad advice? Java itself stores the JDK there. On my PC

c:\> for %i in (java.exe) do @echo.   %~$PATH:i

results in C:\Program Files\Java (x86)\Common Files\Oracle\Java\javapath\javac.exe
This folder is more protected as it belongs to the adm group.
Placing executables on other HD’s normally used for static data storage can (depending on settings) get them out of the sleep mode.

  • That’s b/c Java, like most apps, has an installer!
  • An installer also registers its app and puts it as an entry on the Control Panel\Uninstall section.
  • Processing doesn’t have any of it!
  • The whole uninstall steps for Processing is 100% manual.
  • B/c Processing isn’t “officially” considered installed in both Windows & Linux, the OS might deny it access to some system folders.
  • And %ProgramFiles% is itself a protected system folder.
  • Although Processing can be dumped in %ProgramFiles% folder, it’s safer to do it elsewhere IMO.

Makes sense, but in my three years of Processing, I’ve never had an issue with that from Windows 7 to10. However, at least installing Processing on the same HD where Windows is installed is preferable I guess.

Turns out even when Im able to open the program, by going throught the whole song and dance with uninstalling it properly, turning the computer on and off and reinstalling it, I now realised I can’t run any sketch. It just freezes.

And now I just unpacked it in C: in downloads. Because I didnt know where else

Maybe try out another file archiver/decompressor utility: :man_shrugging:

I used 3 different decompressors :confused: