Java error on startup when I launch Processing

Hi, I’m having a strange error but i can’t seam to fix it. When i launch processing I get this popup and then processing closes. It’s been working without any issues for the past couple months … just sudenly today i’m getting this. I’ve tried replacing the sketchbook, but that didn’t solve anything. I tried redownloading and reinstalling but same …

1 Like

:frowning: anybody?

I’ve managed to install the file on another computer but its not the one I use normally … It’s obviously a conflict somewhere but i’m really not sure how/what to check. I havn’t installed anything in between the time it worked and the time it didnt. Maybe a local update of some sort …

hi there,
i want to help, but also i have problems to understand your report.

-a- second post first:

no idea what you talk about

  • install ( unzip ) processing
  • copy one of your sketch

anyhow miss the info how it play out.

first post:

ok, with processing we must consider 3 locations on your computer:

C:\Users\ < USER > \Documents\processing-3.5.3

when you start we talk about the

C:\Users\ < USER > \Documents\processing-3.5.3\processing.exe

( or any link to it )

  • -b- at first start it makes 2 more directories

C:\Users\ < USER > \Documents\Processing\

what is for sketches, libraries and modes
called sketchbook
if you deleted that you lost all your projects.

  • -c- and a directory i call system directory ( here for windows )

c:\Users\ < USER > \AppData\Roaming\Processing\

where the preference file and old error logs are.

in case if unzip newest downloaded processing for your system
and still not start, i recommend to delete that -c- system directory
possible there is something bad.
what you can loose max with deleting that is any adjustments made in
PDE / File / Preferences /
( like skechbook path and editor look… )

try to be more precise next time.

  • OS name and version
  • processing version ( and bit 32/64? )
  • downloaded filename
  • path information
1 Like

Hi Kll … thanks

So …

a: what i mean is i used the processing program install file that i had and tried it out on another computer and it worked without an itch. So I know that the issue is linked to my current computer configuration and not processing. I can use processing program on that computer now, just not on my own computer.

b: Yes … so this is what i mean by forcing it to reconfigure and recreate the sketchbook directory. I removed it (relabeled no worries I kept all my previous projects safe) and it thus said that they were missing so processing would regenerate the directories … which it did.

c: I havn’t checked that directory … I’ll try and remove it and see if by getting processing to regenerat that directory it’ll work. Thanks a lot, I’ll tell you how that went. Hope its the issue

OS … Microsoft 10
processing version 64bit processing-3.5.3

1 Like

IT WORKED!!! thank you KLL :slight_smile: