Processing will not open past logo screen

As soon as I unzip and try to open Processing, I only get to see the startup logo window for about 3 seconds and then nothing else happens. It dissappears and no app opens.

Expected Behavior
I’m not quite sure. I’ve never used processing before and was downloading it to learn how.

Current Behavior
No application opens, only the logo is shown for a little while.

Steps to Reproduce
I have tried the following steps:

  1. Delete processing, and download a new one
  2. Download the latest version of java
  3. Unzip file with 7-Zip
  4. Try downloading the 32-bit version
  5. Moving some files such as modes and core to other locations than the file they were found in. (I tried moving all of them individually actually)
  6. Deleting the preferences and the sketch book individually
  7. Trying to receive a debug file. This is what happens

C:\Users\Xxxx>.\processing.exe --|4j-debug
‘.\processing.exe’ is not recognized as an internal or external command,
operable program or batch file.

My Environment

Processing version: 3.5.3
Operating System and OS version: Windows 10 Pro
Other information: 64bit

I stole this layout from a different post and used it as a template, I’m not the same person who made the earlier post.

Any help would be fantastic! I’m no expert at computers but I can try to find any extra info that could help.


Maybe your download not finished well. Download it again and try to run it. If it is still not opening post issue on GitHub.