Trouble with python mode


#1

I installed python mode but when I click on python in the dropdown, an error window appears
Title: Python mode Error
Meassage: Cannot start python sketch runner.
I’m fairly new to programming and processing, I’ve done several p5.js sketches and have been writing a lot of python programs.
I’ve googled the error and tried uninstalling and reinstalling and I just can’t seem to get python mode to work…


#2

I should add that processing completely closed when this happens…


#3

What instructions did you follow? Did you install python in your system? Also, what is your OS?

Kf


#4

I followed the instructions on the github page for processing.py in the readme file.


I am running on Ubuntu 16…which has python installed already, I can run python 2.7 or 3.5


#5

Ok, I think it has something to do with the java not python, when processing starts there is a message saying not fond of this java. I tried copying an example from the getting started page, to run a sketch in the default java mode and a bunch of errors were popping up…my internet is not reliable where I am right now so I will have to wait until next week when I get back home and try getting a different version of java


#6

Keep us posted. i’m sure we will figure this out: - )


#7

Ok, I have a not so exciting update… I made sure I had the right version of java installed, and the not so fond of this java error went away but all the other problems remained. Still could not run any sketches in java or python.
I had already tried deleting processing and re-extracting the files and starting over in case I set something up wrong, so instead I tried downloading the 64-bit version instead of the 32.
Either something went wrong on the first download of processing, my computer doesn’t like the 32 bit version, or I was just doing something wrong that I don’t realize.
After extracting the 64-bit version everything is working fine. I’ve run a couple of examples in both java and python mode.