[SOLVED] Py mode not working


def setup():

def draw():

Today I bought a notebook, where I installed Processing,
Java projects work fine, but for python I run the code and it immediately stops

1 Like

Have you granted authorization for the Py Mode to access your LAN when the firewall window popped up? That’s all I can think about for now. :roll_eyes:

Yes, Im 100% sure I did it

Just a detail: your rect(100,100,100) statement is missing the 4th argument (height). :flushed:

def setup():
    size(500, 500)

def draw():
    rect(100, 100, 100, 100)

Have you already explored the Python sketch examples to check if they work? Hit CTRL+SHIFT+O for it. :snake:

(I wish it was just the 4th statement the problem)
Nope, examples dont run

1 Like

I have been using Processing 3.3 with Processing.py in my classroom for quite a while with no problems. A student just brought in her MacBook Air, onto which she loaded Processing 3.4. We’re seeing the same Python mode behavior as mentioned above - when the program runs there’s no error message, no window display, nothing. The console area scrolls a little but nothing is displayed in it. Java mode seems to work. I see that the title of this message is marked SOLVED but I don’t see any solution posted.

The solution is inside here


worked for me.
install the Oracle JDK 1.8* ,and set the bin path to the environment path.

I tried the downloaded connected to this solution but was met with a Mac error. Has anyone else experienced the same?