Can't run "Hello World" in python mode

Basic problem here. Any tips would be most welcome. I can run code in Java Mode. And I have Installed Python mode. But even the most basic code won’t run. e.g.:

ellipse(50, 50, 80, 80)

When I click the “Run” button, it turns white and green for a moment, but then turns back to gray and no drawing window ever appears.

EDIT:
Tried removing and re-installing python mode. Tried restarting computer. Tried removing Processing and re-downloading latest version (3.5.4) and re-installing Python mode. Tried running the Processing app off the desktop instead of the Applications folder. Still no luck.
Macbook Pro, OS 10.14.6

Does Processing.py rely on a particular version of python (e.g. 2.7) or a particular path where it should be located on a Mac? I have done other Python programming on my MacBook Pro, so things may have been moved around.

Python mode works fine on my Mac Mini that also runs OS 10.14.6…

Welcome, @Spiff

Processing installs everything your system needs when you add Python Mode via Processing (it relies on its own Python interpreter, not the one installed on your system).

Perhaps try deleting your Processing folder, located at /Users/<your_username>/Documents/Processing/. Also, delete your preferences folder at /Users/<your_username>/Library/Processing/.

Then re-open Processing and add Python Mode again.

1 Like

Py.Processing.org/tutorials/python-jython-java

Thanks for your information and suggestions. Still not working, however. I tried:
• Renaming and moving the Processing folder from Documents onto my desktop (I wanted to keep the previous processing scripts I had written, so I didn’t delete the folder.)
• Deleting the Processing folder from my “Library”, as you suggested.
• Deleting the Processing app. (Probably to no effect.)
• Restarting computer, re-downloading Processing, re-adding Python Mode.

I’m at a loss about what else could be conflicting with Processing running in python mode on this particular machine.

Let me know if you have any other suggestions. I really appreciate the help.

-Spiff

I find that I am able to run Processing.py from the command line.
https://py.processing.org/tutorials/command-line/
So that will be my workaround for now. Thanks again for your help.

-Spiff

2 Likes

@Spiff thank you for your persistence! Welcome to the community!

Consider opening an issue at: https://github.com/jdf/Processing.py-Bugs

1 Like

Does your Processing path or sketchbook (…//Documents/Processing ?) path contain non-ASCII characters ?

No non-ASCII characters in the path names. Processing is installed in the standard “Applications” folder, and the sketches are in /Documents/Processing

1 Like