Processing 3.5.4 not working with python mode

So after I googled online for a while I still can’t find the solution.
I tried mostly everything I can find on the web. Reinstalling, firewall etc.
My java mode works fine, just python mode is not.

Welcome @wunaizcy

I have a few questions:

  1. What OS are you using?
  2. Can you switch to Python Mode (using that mode button at the top-right of the editor)? Did you manage to install Python Mode from the Contribution Manager window?
  3. Are there any errors in the Console (black area at the bottom of the editor) when you try and run a Python sketch?
  4. Would you happen to be using some networked account on a Windows machine?

1.I am using windows 10.
2. Yes I am able to switch mode and able to click run, the run icon will turn green but nothing pops.
I installed from the add mode in processing.
3.First there is nothing in the console then if I tried to run another sketch this will show:
removing C:\Users\smith\OneDrive\Desktop\cs5001\hw10\pacman_game_starter\pacman_game_starter.pyde
at javax.swing.AbstractButton.fireActionPerformed(
at javax.swing.AbstractButton$Handler.actionPerformed(
at javax.swing.DefaultButtonModel.fireActionPerformed(
at javax.swing.DefaultButtonModel.setPressed(
at javax.swing.AbstractButton.doClick(
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(
at java.awt.Component.processMouseEvent(
at javax.swing.JComponent.processMouseEvent(
at java.awt.Component.processEvent(
at java.awt.Container.processEvent(
at java.awt.Component.dispatchEventImpl(
at java.awt.Container.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.LightweightDispatcher.retargetMouseEvent(
at java.awt.LightweightDispatcher.processMouseEvent(
at java.awt.LightweightDispatcher.dispatchEvent(
at java.awt.Container.dispatchEventImpl(
at java.awt.Window.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.EventQueue.dispatchEventImpl(
at java.awt.EventQueue.access$500(
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.awt.EventDispatchThread.pumpEventsForFilter(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(
4. I don’t think so or I don’t know this is my pc and I’m the only user.

I’m afraid I haven’t encountered this issue before. I don’t have any problems running Python Mode on my Windows machine (same Processing and OS as far as I can tell). I have Processing running from a folder on my desktop; I don’t use OneDrive.

Maybe it’s your code? Have you tried creating a very simple sketch – like, a one-liner with just square(10, 10, 10). See if that runs or if you get the same error.

Maybe somebody else on the forum could help …

1 Like

Don’t use remotely synchronized folders to store Processing sketches! :fearful:


My code works because I got it tested out on my friend’s computer.
Thank you for your information. :slight_smile:

I think its just my desktop is under onedrive, but I’m not using it remotely. Can you explain it more?
Very apprcreciate.

Maybe create a new directory ‘above’ the OneDrive one, like C:\Users\smith\processing. You can store your Processing files in there so they aren’t synchronized.

You might even use a Git repository so those files are version-controlled (and duplicated in the cloud).

This is where my processing is at C:\Users\smith\Documents\processing-3.5.4
and this is where the sktech i want to run is at C:\Users\smith\hw10\pacman_game_starter
Unfortunaly this doesn’t solve the issue.

Hmm. In the Processing editor, select File > Preferences. Check that the Sketchbook location isn’t in the OneDrive directory. Restart Processing if you change anything.

1 Like

@tabreturn has a broguht a good point! Checking at the preferences were your sketchbook a.k.a “Documents/Processing/” is stored, because the libraries and Python Mode files are kept there. It could be an issue, I suppose.

install Oracle JDK1.8* and add the bin path to the system environment.

Welcome @qfxfox! I’m afraid this might not be a good idea. The Processing IDE always uses its own Java runtime, not the one from the system, so we never recommend installing another JDK just to try to solve Processing IDE issues.

[EDITED: Changed reply to clarify it is OK to install other Java runtimes. Processing IDE just won’t notice them]

1 Like

@villares Doesn’t seem to be a problem on linux (and I can’t imagine its any difference on Windows.
See result from terminal (ie installed java) compared with processing-3.5.4.

1 Like

Cheers @monkstone!
I guess my message sounded ambiguous! Sure, there is no harm in installing Open JDK.
I just wanted to say that I think it is not a good idea to suggest installing any other Java in order to solve Processing IDE issues, like the one being discussed on this thread, as Processing won’t even “see” it.

1 Like