Processing wont start

Hey, i wanted to play around with processing but i cant seem to get it working. These are some things i found out:

  1. when i launch processing for the first time it starts up but if i try to run some code it crashes
  2. if i try to launch processing after that it shows starting screen for few seconds and then nothing happens, all i get is stuck java process that i have to end manually
  3. if i delete Processing folder in AppData i get to point 1. processing starts up, but crashes after i try to run anything

when i tried to run processing in my clean win10 VM everything worked ok, but i dont really want to use my VM just to run processing.

Could you give us more details about your environment?

Sure, im running Win 10 Enterprise edition 64 bit, i have JDK 1.8.0_131 installed if that means anything, also my JAVA_HOME is correctly set to the location of my JDK. But from what i can see processing uses its own versin of java to run. I dont really know what else to post other than my operating system version.

I thought i could find something in Processing/console folder in AppData but bot .err and .out files are empty

Besides the usual “Uninstall reinstall” suggestion, I have to admit I’m just as lost.

However, if you’re main goal is to quickly run some code you’ve stumbled upon (and you have wifi), I’ve found openprocessing quite handy. Really depends on your use case.

Can you open Processing.exe from the command line? (Shift+click in the explorer window then click open command prompt here)

If there is a crash there should be a stack trace with maybe some more information…

im not getting anything when running processing from command line, even when i try redirecting output to a file there is nothing.

I experienced something similar. Processing 3.4 on Win7 worked in the morning; in the afternoon, the About panel appeared for some seconds, then Processing crashed. I didn’t get any error messages when launching Processing from the command line.

Turns out I simply had not enough memory (< 1.5 GB) on my hard drive left! I freed up about 8 GB, now Processing is working again. Guess the Java VM tries to allocate some (huge) amount of memory up front, and sillently crashes when it can’t.

Hi. I am using Processing 3.4 on Windows 7. Same issue occurred with me as well. I cleared 11 GB. But I am getting the same thing. The software just opens for few seconds and crashes before the editor opens. I am completely stuck now. :frowning: