Pre-3.0 Releases Work, but 3.0+ Crashes on Startup With No Error

Hey everyone, I used to have Processing a couple of years ago, and just wanted to get back into. Before I get into it, I should start by saying I have been scouring the forum and github looking at similar issues and trying all of their fixes, but to no avail. I’ve been seeing a lot of issues with newer versions where processing will crash and give a big error message - this is not what I am experiencing. Rather, the splash window appears as if processing is launching, and after about 1-2 seconds it crashes, and nothing happens - processing doesn’t start, it doesn’t generate any new files (in the directory where I extracted everything, Documents\Processing, or AppData\Roaming\Processing). If I install any version before 3.0, it launches and everything works fine, but I don’t want to be running the old outdated software, and any release above 3.0 I’ve tried has done the same thing. Any ideas? I feel like I’ve tried everything I can given my very limited knowledge of this kind of thing. It’s just a little frustrating at this point, because I’ve seen this exact problem on the github page, but they were told to take the problem here and the issue was immediately closed, and I have yet to find any answers here, so I’m kind of at a loss. Any help is greatly appreciated, thanks everyone!

please provide more info ie system etc…

I’m on Windows 10 (build 19041.1083). Not sure what else would be helpful

is this a clean install? And are you using the official download from the processing site? Have you also downloaded anything to do with java, ie jdk or other

I used to have processing, but I was trying to reinstall it. I tried deleting the Processing folders from AppData\Roaming and from my Documents folder before installing as well. Downloaded from the official site, and I have updated to the newest jre and jdk 16.
Also, I’ve tried downloading processing to multiple different drives and installing it in different places and the same thing happens each time.

processing should work straight out of the box without a need for java extras and sometimes java installs can cause issues. I’d recommend a simple sys refresh but that may be a bit hardcore, but without knowing for sure what has been installed on your pc its difficult to diagnose.

As a programmer I went through multiple issues with configuring build projects etc, and in the end I simply created a system image on a separate hdd. Now my system can be re-installed to a working config in about 5 minutes with sys reset. All my personal files are also stored on another hdd so, wiping isnt an issue.

Obivously this may not help in this instance but if you are planning on using processing long term it may be worth considering.

Interesting, I’ll have to look into that more and see if I can figure anything out. The only other thing I can think of that could possibly have gone wrong, is I may have slightly edited some environment variables. My knowledge about this kind of thing is super minimal so to be honest I don’t even know what the environment variables do, I was just following a tutorial that had me edit one. What’s weird to me is the fact that the older (pre-3.0) releases work just fine, as well as the fact that most people I see with problems crashing on startup get a big error message from the JVM, but my system appears to just do nothing.

Thanks for the help!