Processing and Windows 10


#1

Hi,

Processing does not working on Windows 10 (last update). 64 bits 32Mo of ram.
when I try to run Processing it takes more 3 minutes to appear on screen and after I write code setup and draw it takes and other 3 minutes and Viewport does not appear even after an hour of waiting. :frowning_face:
Does some know about this trouble, it seems some poeple have the problem and I don’t see any solution.

Regards.
GG.


#2

this might be wrong info
pls check again

also check for JAVA
like in a command window type
java -version

pls also descipe detailed what and how you installed processing


#3

Sorry I make a mistake. 32 Go of ram and
java version is build 1.8.0_191-b12 64 bits.
French version of Windows 10.


#4

what can i say,
i run processing 3.4 on

  • win7 32bit 2GB RAM
  • win7 64bit 4GB RAM
  • Raspbian Linux 32bit 1GB RAM

and yes,we have to see that intro picture for about ?15sec?
and then the IDE editor window come up.

and with a code like

void setup(){}
void draw(){}

press run and see the small canvas window in about 3 sec…

so pls install processing 3.4 again, and report detailed every step
incl file names…


#5

When I am running unzipped processing verion nothing appears before 2 or 3 minutes.
The windwow appears after few minures with no code, I paste your code .
When I am running the code you send me, nothing appears and I try to rn the code
and the java application must be deleted with Task Maganager, otherwise we
cannot delete IDE application.
To install processing I downloaded, I unzip container and from the directive unzipped
I create directory named Processing in my Program Files and I run processing.
That it.


#6

i already wanted to ask you if you possibly have a cheap graphic card ??
but i worry you would not understand the joke…

i asked you to do it all again,
and pls be very exact in your description…

download what file from where
unzip to where
start what file how

even i not know windows 10
i expect ( like from windows 7 ) that,
at the very first start, you need to allow java to run ??
if you there disabled that???


#7

i try it all in pictures:
download processing from internet:
( here select windows 64bit version )


and save it ( to default download path of you browser )
snap_0008
see the download progressing:

also can look via windows explorer

and after download see:

and now unzip ( with your usual tool: ) to a drive and path:

after unzip you can start processing directly from there ( or create a desktop icon /short cut )

you will be asked ( only first time ) if you want to run that software
snap_0015
now see the intro picture
snap_0016
and after some seconds the IDE editor window

you can write some code and try to run it

and get your first CANVAS window

( i play that for you on a old win7 64bit 4GB RAM laptop )


#8

java is always permitted to run, on this PC I am running Arduino IDE and java Platform SE binary is working fine.
When I quit Arduino IDE the java machine is removed correctly from the task manager.

When I try to run Processing in the task manager I have multiple instance of java and it stay forever until I reboot the machine.