Missing Sketchbook - Processing Won't Start

I have downloaded the latest version of Processing after a major file reorganization. Processing will not start because it says the Sketchbook is missing. I have checked for a preferences.txt file and there isn’t one. What do I need to do to make Processing start?

1 Like

Did you try to alter this file via Menu File | Preferences or whatever?

No, but it is entirely possible that in reorganizing my files I may have messed it up. I have downloaded another copy of Processing thinking that might help but it did not.

best is to delete processing system dir ( yes, where the preference file is )]
on win 10 it is

c:\Users\ < Users > \AppData\Roaming\Processing\

if your sketchbook path was changed need to adjust it again.

1 Like

For reasons I cannot explain, I have two folders under Windows in addition to Users/Public :
Windows /Users/freds (the original less all my data)
Windows /Users/freds.000 (a copy with all of my data)

There is no “AppData” folder under users/freds.000.
There is an “Appdata” folder under users/freds but it does not contain a “Roaming” folder.
It is users/freds/AppData/local/NPE/NPETraceSession.etl

Using the file search, there is one “Preferences.txt” file and it is for my Arduino stuff

repeat: i talk Windows 10

sorry, i forget to mention,
after delete the processing systems folder start processing and it will
again create 2 directories.
c:\Users\ < Users > \AppData\Roaming\Processing
c:\Users\ < Users > \Documents\Processing\ with some subdirs.
where also your sketches can be saved.

none of this is happening under

for a damaged windows i can not help

You download Processing for Win 10 x64, then you unzip the file. Place this in your documents folder and run the executable. What happens? Same error or you get something else?

Not sure about this /Users/freds.000. How is this related to the Processing unzipped folder?

My preferences is at C:\Users\usr\AppData\Roaming\Processing


I removed all processing.exe files and all processing zip files. I then downloaded a fresh copy of the zip file and extracted it. I ran processing.exe and received the same error - can not find the sketchbook. However, in your instructions you said to delete the processing system folder and start process. I am afraid I am unclear as to what or where the “processing system folder” is. Could you elaborate, please?

Can you provide the actual message that you get? I prefer if you copy and paste the whole message here adding three back ticks before and after the text to conserve formatting. If you cannot do this, a screenshot then.

Because you cannot create the sketch makes me think it could be a permission issue not to be able to write to the temp folder to create a temporal sketch. Can you try to open an existing sketch (one of the examples that comes with Processing) and see if you have the same issue? The location of the folder in question in my machine is: C:\Users\usr\AppData\Local\Temp\

Having the exact error message helps a mile here.


I am sending 5 screen shots:

  1. The files at Windows ©/users
  2. The files at Windows ©/users/freds.000
  3. I went to my documents and found Processing.exe and prepared to start Processing
  4. This is the first error I received
  5. And this is the second

yes, looks like there is a ?old? sketchbook folder
but this is not a usable user directory,
i think its a windows internal backup ( after you did what? a failed user move? )
( and what windows backuped ( like not the appdata/roaming/ folder , who knows )
you not show

you unzip processing to somewhere
? / google drive /…/dropbox / … /
and that in a situation where nothing work,

anyhow a bad move, i would understand that you want your work backed,
i also not do that anymore, just from time to time ZIP the sketches to ?networkdrive … ?

but the app itself there in google drive… is not useful, if lost just download a
or newer…

again, easy path: unzip to:
c:\Users\ < Users > \Documents
c:\Users\ < Users > \Documents\processing-3.5.3\
c:\Users\ < Users > \Documents\processing-3.5.3\processing.exe
get new directory:
c:\Users\ < Users > \AppData\Roaming\Processing
c:\Users\ < Users > \Documents\Processing\

if processing can not make that 2 directories or finds a bad
c:\Users\ < Users > \AppData\Roaming\Processing\preferences.txt
( but you did not find that??? )

might think about a new windows installation.

I am uploading the file structure under “users/freds” just so you know whats there(or better whats not there). Reinstalling Windows may be the answer.

Thank you very much for taking the time to consult with me. I greatly appreciate it.

hm, that user directory is very empty, not even

lucky windows run at all.

OR that is not your windows user directory at all??
just verify,
windows / notepad /(edit some text ) / save as /Documents/test.txt
and find where it ended up.

Well this was s surprise. See attached edited screen shot.

in the first step NOT use any network / or synced drives for processing.
just had a case where a sketch path to HD what had a backup to a NAS, it not work.

here you try under OneDrive… ( please, that we not test now )

the idea was to use / select /Documents/ path
( i see it at the left under ( this PC,Desktop/Documents/Download )
click on it
and the filename was “test.txt” ( no *… )
and after it is saved , use the filemanager ( File Explorer ) to find it.
because under
was NO Documents directory

other idea,
( besides windows reset / install )
as USER freds still work ( and possibly is admin )
try to make a new windows user and hopefully
it is created with a good default path structure.
( and you could make that user also admin but i am not sure if required )

you are correct, I misunderstood your directions. With some help we loaded Processing where I think you suggested: This PC/Documents and it worked. My Windows said that it would not work under Google Drive. I think that is what you were saying. Well, its working and I am back in business.

Thank you again for your help and counsel. I greatly appreciate it.
Fred Stout


Shame on me. I failed to do a reasonable job of proofreading my last reply. I sought help with my Windows problem and he moved the Processing package to FredStout/documents which is what I believed you asked me to do (and I failed to fully understand). You were correct.