Error: "Problem while trying to get the sketchbook"

Hi im getting error when I ever open Processing 3.4 and its saying:
The messege title is: No sketchbook
What the messege says: Problem while trying to get the sketchbook
Here is a pic of the messege:

i hope u help me and find me a solve i will be really thankful if u helped me and im really on need to fix that cuz im learning new on processing and all my friends on school is getting way much better than me on it cuz they train and i need to train and we get homework so i have to fix this really fast

Have you tried uninstalling Processing and then installing the latest version? Have you checked that the sketchbook directory exists and has the correct permissions?

yea i unistalled it and reinstall again and i dont know what u mean by Have you checked that the sketchbook directory exists and has the correct permissions
and can u send me your processing version so i test if works with yours

Try deleting or moving the sketchbook folder so it creates a new one!

where i find the folder?

It’s the folder called “Processing” wich is normally on your folder “Documents” ( or equivalent folder for Mac / Linux ).
Try first to verify the path of your sketchbook :
Files --> Preferences --> Emplacement of your sketchbook
I put it in the root of my OS, so I have that for example :

The path needs to lead to your folder “Processing”. So if you move it, you have to fill the new directory in order that Processing find your sketchbook.

i already fixed it :smiley: the problem was on the newest version it got errors i download one old from it and it worked fine and thanks for helping too lol

Had a similar problem where a new Processing-installation crashed at every startup: “The sketchbook folder no longer exist. Processing will try to recreate…”. The problem was that during the install, Processing for some reason had chosen the drive D instead of drive C.

Solution: change the path in preference.txt file:

sketchbook.path.three=C:\Users\ [Username] \Documents\Processing

How to find preferences.txt

  • Windows XP: Documents and Settings -> [username] -> Application Data -> Processing -> preferences.txt
  • Windows Vista and 7: Users -> [username] -> AppData -> Roaming -> Processing -> preferences.txt
  • Mac OS X: ~/Library -> Processing -> preferences.txt
  • Linux: ~/.processing -> preferences.txt

Note: Because AppData and Application Data may be considered hidden or system folders on Windows, you’ll have to ensure that they’re visible in order to get at preferences.txt!