Launcher seems to be ignored in the preferences

Hi! In my preferences.txt I have a line like this:


This used to work fie in the past but not anymore. When I press CTRL+K it opens a terminal window which closes immediately. Inside the script I added echo "1" > /tmp/AAA to verify it is running, but the file AAA is not created. Calling from the command line works as expected.

I tried replacing launcher= with launcher.linux=, but no change.

I can’t use Show Sketch Folder. Any suggestions?

Do you know around which point version of PDE this stopped working?

Unfortunately not. In the current version when I choose Show Sketch Folder it opens a terminal window and closes it immediately. I just tried in 3.4 and it doesn’t even seem to try :slight_smile: So no quickly appearing/disappearing window.

I guess it’s something related to my system.

If it is your system – does a regular bash/sh shell script work? Any chance it is permissions related to your custom fish shell?

Oops ignore what I wrote earlier: it does work with 3.4!

I had commented out the part that opens the window and added a line that creates an empty file in /tmp just for testing. So when I tried with 3.4 it actually worked fine, it created that file.

So something in the most recent Processing breaks this in my system: the script doesn’t seem to be executed at all (my test file is not created) with bash / fish / sh.

It sounds like you have enough information to submit an issue to

To investigate yourself you could try searching for “launcher”

…and then using Blame view to inspect code around that feature, e.g.:

I see the problem at



had priority if it was set. Now it does

if(Desktop.isDesktopSupported()) { super.openFolder(file); }

which triggers


in DefaultPlatform (ignoring the preferences). Thanks for the help! Knowing what’s the issue is good enough for me :slight_smile:

Really glad that helped.

Would this still count as a bug for others? If so, it might still be worth filing a bug or feature request.

I think it is confusing to have the launcher option which gets ignored if a certain condition is met. But I guess preferences.txt is mostly undocumented. I’ll let someone else open the issue :slight_smile:

I’ll leave a keyword here in case someone struggles with this: xdg-open

1 Like