Processing closes before fully launching. (help me read --l4j-debug)

Hello I’m trying to install processing on my desktop but for some reason the program won’t open, i’ve tried the different solutions posted on the troubleshooting site and other posts. but the problem remains. I tried to find the preference file as many said deleting it usually fixes the problem, but the file isn’t anywhere to be found. so i ran the --l4j-debug. and i’m hoping someone here can see what the issue might be?

Version:	3.9
CmdLine:	C:\Users\Razer\Desktop\processing-3.5.4-windows64\processing-3.5.4\processing.exe --l4j-debug
WOW64:		yes
Working dir:	C:\Users\Razer\Desktop\processing-3.5.4-windows64\processing-3.5.4\.
Bundled JRE:	java
Check launcher:	C:\Users\Razer\Desktop\processing-3.5.4-windows64\processing-3.5.4\java\bin\javaw.exe (OK)
Heap -Xmx:	Requested 256 MB / 0%, Available: 7970 MB, Heap size: 256 MB
Substitute:	EXEDIR = C:\Users\Razer\Desktop\processing-3.5.4-windows64\processing-3.5.4
Add classpath:	lib\pde.jar
Add classpath:	core\library\core.jar
Add classpath:	lib\jna.jar
Add classpath:	lib\jna-platform.jar
Add classpath:	lib\antlr.jar
Add classpath:	lib\ant.jar
Add classpath:	lib\ant-launcher.jar
Launcher:	C:\Users\Razer\Desktop\processing-3.5.4-windows64\processing-3.5.4\java\bin\javaw.exe
Launcher args:	-Xmx256m -Djava.ext.dirs="C:\Users\Razer\Desktop\processing-3.5.4-windows64\processing-3.5.4\\java\\lib\\ext" -Djna.nosys=true -Djna.boot.library.path=lib -Djna.nounpack=true -Dsun.java2d.d3d=false -Dsun.java2d.ddoffscreen=false -Dsun.java2d.noddraw=true -classpath "lib;lib\pde.jar;core\library\core.jar;lib\jna.jar;lib\jna-platform.jar;lib\antlr.jar;lib\ant.jar;lib\ant-launcher.jar"
Args length:	405/32768 chars
Exit code:	1

In the settings of processing is usually a link that leads you to the prefs file. Not sure if that fixes your problem tough.

1 Like

It doesn’t cause the Preferences file isn’t where it says it should be

Users -> [username] -> AppData -> Roaming ->

Processing -> preferences.txt (on Windows Vista and 7)

This is what the defaults.txt doc tells me. but I can’t find any folder from processing in that location

since I have no windows at hand, I could not look for its location, but we have it happily running on a windows computer in an exhibition right now.

maybe you can try and put a prefs file into the expected place…

My computer started getting java errors in other areas, so i’m going to do a fresh install of windows. see if that fixes my issue. seems my pc has some wonky stuff going on. will update once i’ve tested it.