The Processing doesn't Run the sketches in my new laptop

please format code with </> button * homework policy * asking questions

The Processing doesn’t Run the sketches in my new laptop,
That tiny window that shows what you did doesn’t run in my new laptop although there’s no errors.
I already tried changing preferences setting especially the Location folder but it doesn’t work, when I save and reopen the sketch I find the preferences settings all back to default again…
I’m new here I’ll appreciate your help.

Hello @Anki,

This works for me for saving the preferences for Processing 4.1.1 on W10:


Oh thank you so much for your response it worked, now the Preferences location is changed and saved but still nothing happens when I press run and there’s absolutely no errors with the codes :smiling_face_with_tear:


Sometimes I do not see the sketch window and I go to preferences and select a display and it works!

Try going in there and selecting one (may be just one!) and see what happens.



Thanks for your gentle response glv, I just tried that but unfortunately the app isn’t letting me to edit that part at all like it’s not clickable at all… :smiling_face_with_tear: :smiling_face_with_tear:

I have 2 monitors so this may not apply in your case.

What operating system?
Which version of Processing?

Try a sketchbook folder that does NOT have spaces.

Latest version here:


My laptop is msi nl eindhoven 5706 windows 11
And I’m using the latest version of this app in fact I’m pretty confused that what could be potentially causing such a problem cuz I’ve had an old acer with windows 7 and on that laptop this app was working perfectly but with this new laptop it doesn’t… :sweat_smile: