Error message when starting python mod

When I start the python mode in processing I get following error statemant:

I found a website that has a workaround for this issue.

However I can’t seem to find It is not in my Python 3.9 folder and nowhere in Processing/modes/PythonMode/... .
Does anybody know a solution for one of these issues since that could fix the other issue as well.

It looks like you’re using Python Mode for the Processing IDE? This uses Jython to compile your sketches, not normal Python or Conda. It won’t look for packages or any other configuration settings in your python3.x and miniconda3 directories.

However, there’s a EXTRANEOUS_WHITESPACE_REGEX line in the Python Mode file: \Users\<user>\Documents\Processing\modes\PythonMode\formatter\ I’m not sure this will help, though.

Someone reported this issue at, but somehow seemed to resolve it (or it resolved itself). It’s not clear how, though :confused:

I can confirm that Python Mode is working fine on my Windows machine. Maybe try moving \Users\<user>\Documents\Processing\ elsewhere (so that you have a backup), then reinstall Python mode? Maybe a Windows restart, too?

1 Like

Sorry, forgot to add that, yes, I am using the python mode but I’m running Python 3.9 as well(don’t know if that changes anything).
Quick update: I started Processing in python mode today because I wanted to try editing but I’m not getting the error message any longer. So it looks like it somehow fixed itself.
Appreciate the help though.


Welcome @Bobby54!

Please note the Python in the Processing IDE’s Python mode is its own Python 2.7 (a Jython interpreter that can talk to the Processing Java tools), so it has nothing to do with your Python 3.9, anaconda or any other Python instalation :slight_smile:

1 Like

Hi tabreturn,

Started reading your book Lean Python Visually a couple of hours ago.

I am having this same problem i.e. the same error message appears. So I closed and restarted it. The error message is gone, but the spacing between the code is off and, more importantly, nothing prints in the console.

For example:

size(500, 500)
print(‘Hello, World!’)

When run, shows just a blank screen.

I have re-installed it all, but the same problem persists.

Do you have any ideas?


I completed another no starch press book “Python Crash Course” and this used Sublime Text. So I’ve got the basics covered and have noted that another poster wrote that Processing works off its own python IDE version.

Hi @Oscar_Sheen

Firstly, make sure that you’re using Processing 3 (version 3.5.4).

Maybe try drawing something simple in the display window, like a white circle:

size(500, 500)
circle(50, 50, 50)

If that works fine, maybe it’s some issue that only affects the console?

1 Like

Downloading Processing 3 (version 3.5.4) fixed the problem.

Note, the same error message came up. But I just closed the program then started it again. I then entered the code per page 5 of your book and it worked straight away.

Looking forward to completing your book and thanks for the prompt reply.