PythonMode not working. (No display window?)

Hello everybody,

I’m having some big trouble with pythonmode. Run button seems like not working.(Not turning to green when I click on it.) And no display window is appearing. I’m just getting this warning on console, nothing else. (When I select the Python from the java screen in mode selection) ;
“Users\User\Documents\Processing\modes\PythonMode\formatter\ FutureWarning: Possible nested set at position 1
EXTRANEOUS_WHITESPACE_REGEX = re.compile(r’[[({] | []}),;:]’)”
Any help please? Thanks.


Hi, @palmiye!

Are you using perhaps the new Processing 4 IDE?
Python mode unfortunately is not working yet on Processing 4 :frowning:

If this is the case, try downloading Processing 3.5.4…


Hi, @villares
I tried it both of them. Currently, I’m still trying to make it work with 3.5.4 but unfortunately nothing happens…

1 Like

Oh, sorry to hear that!

Maybe try a fresh sketchbook (or Documents/Processing, depending on you platform)?
Processing 4 might have changed some configurations.

You could also open an issue at

I’ve completely deleted everything Documents/processing and roaming/processing, even Java. Freshly downloaded the 3.5.4 again. But no luck… I’ve opened an issue with a different user name. It’s a strange problem for sure. I hope someone with a similar problem will see and help me out.



Hi Palmiye,

Did you manage to solve this issue as I am new and am receiving exactly the same error as you are: “… … EXTRANEOUS_WHITESPACE_REGEX … …” ??

I re-installed it and still got the same error message. Thanks in advance.

1 Like