Android mode hangs on Android SDK notification

Well, I tried following the Get started tutorial on the Processing for Android page but after downloading the Android mode, I tried to switch to it and all I got was a “Cannot find an Android SDK…” message box with nothing on it

I can’t close it or open Processing again cause it’s actually still open.


In that post they say that they had the same problem but they had to kill the process every time to make it work. I don’t know how to do that because I’m really new to programming and all this. Also I really don’t wanna do that every time I wanna use the Android mode

I’m using an Ubuntu 18.04.4 64bits OS. If there is more info that you need to help me please let me know

1 Like


I appreciate your help, now that you have just started programming for android.
I ran into problems as android mode suddenly stops working
I have tried to reinstall it in every possible way and I cannot
windows 10 64 bits

I have tried dowload sdk manually, also automatically but it does not work

again download processing 3.5.4 but it doesn’t work either …

Same here, I tried to download the sdk manually but I don’t know if I did it incorrectly or it just doesn’t find it.
It just wouldn’t work so I had to give up on that, at least for now :disappointed:
Still, if there is someone that may know how to solve this, it’ll be really appreciated

Hi @dinoelectro @UnaLuz
Could you check the location in the preference file?
You can do so by clicking Open File > preferences and then click on the link on the bottom preferences.txt. There you can see and also modify the path like “android.sdk.path=D:\android\sdk”


Well…I just checked and I don’t have that line, should I just add it?

The only lines I have that say something about android are:

1 Like

Yes, it’s necessary. I think that’s why Processing can´t find it.

in the preferences.txt file it does not indicate the path of the sdk.

Now it’s working, thanks Noel

1 Like

I’m glad for you that it’s working.
BTW. If you have time at some moment I would be grateful, if you could test some codes on GitHub here. It’s to verify if they work on other devices and Android versions as well.
Just post an issue there if it’s working or not.


ok I am going to review them … greetings

1 Like

You do know that the fastest way to test them is with the app APDE?
It compiles in seconds. But you have to use the “App mode” for some codes, depending on their ‘permissions’.

Hi again, I tried it but it still doesn’t find the SDK, I’ll try to reinstall the SDK again but I don’t think that’ll do it

Sometimes it’s good to deinstall Processing as well by removing the whole directory in the program files directory and reinstall everything.

hello i am testing the example codes, they all work fine in APDE except “flashlight” and “LED notification”

I found the example of “speech recogniton” very useful, I am just a beginner in programming Android devices but I am very excited about everything I have learned

I tell you again I have problems with the adroid mode this error appears in the console:

1 Like

A strange error. Verify the existence of the build-tools folder within the SDK folder. I uploaded this folder on Google Drive. If you want you can download it here. Just unzip it and place it in the SDK folder. Also, it says that the SDK folder has to be writable. Just right-click this folder choose properties and then disable “only read”.

1 Like

I am having the same message here: “The Android SDK could not be loaded…”
I am on Windows 10, Processing 3.5.3 and Android SDKs 29,28,27,26. I noticed on my preferences.txt it didn’t have the path, so I added it, but, when I open the IDE again, it seems to change the file deleting the path.
I put the path as


I already solved it, android mode, suddenly stopped working on my computer, the reason I do not know

the solution was as follows:

Install android studio, then with sdk manager update sdk tool,

in processing change the path of the sdk (C: \ Users \ PERSONAL \ AppData \ Local \ Android \ Sdk) and voila

1 Like

Hi @aabueno welcome to the forum.
It seems that there is a problem with the proper SDK file.
But as @dinoelectro said, that the SDK manager can be used to properly update the file; you don’t need to download the whole Android Studio packet. You can download the manager separately here, almost on the bottom of the page under the title “Command line tools only”.

Thank you very much for testing. The Flashlight will be fixed. @akenaton already pointed out that it could not work for versions above Lollipop. What is the device and version you used to test?
And what exactly went wrong with the Led notification?

Hello, I am testing the example codes with HUAWEI Y9 with android Android version: 8.1 Oreo
The code compiles and installs correctly, but immediately the app closes, despite having given it the necessary permissions

the warning message on the console says camera deprecated

@dinoelectro ===
how have you given the permissions???
(camera deprecated is only a warning)