Cant locate SDK in android mode

I have installed android mode for processing, but i just cant get past the “Locate SDK” dialog:

Annotation 2020-04-25 163457

I have followed processsing’s tutorial on this,
installed the android studio, android command line tools,
Done research on this and other sites and nothing has worked.
Need help. Thanks.

Have you read this topic?


  1. So I tried that article as well as this article:
  2. Added the file source and version to the preferences.txt file
    (pretty sure the SDK version I downloaded was 28 but not 100% sure)
  3. Looked in the device list and my Kindle Fire was on it! :grin:

More problems though:
I tried to “run on device”…
initialization and build worked fine (that i am aware of), but when it actually tried to run the sketch on the device it failed:

Not sure exactly what the problem is but seems to have something to to with debug, and possibly device communication?

Similar Issue with trying to run sketch on emulator:

On the second one, I see that you are running the sketch on the emulator(that never booted).
Is that correct? I was never able to run the emulator on my PC.
I only manage to run with a USB cable, and only with the correct driver for the device.

OK. :slightly_smiling_face: So what do you mean by “boot”?

Like booting the PC, making it available to perform any computing operation.
That what’s said (in red) in the console. Have you tried using USB?
As a matter of fact, I only use APDE on my tablet. It compiles as fast as

@Java.SourceForger ===

  • What OS is running your (real) device? ?
  • Can you put your generated Manifest
  • Verify what is the SDK version that you have installed
    This error means either that you are targetting (minSdkVersion) a version higher than you device one or are targetting (targetSdkVersion) higher than your installed SDK.

It’s a windows PC. And yes. It’s probably possible that I’m writing down an SDK version that’s higher than one I’ve installed.
How do I know what sdk version I’ve installed?

@Java.SourceForger ===
i was not talking about your laptop but your phone…
put your Manifest.

Oh, OK. The android device that I have is a kindle fire.

He meant the generated AndroidManifest.xml
See at the bottom of this file.
Also you have do say what android version you are using on your real phone.
Like Lollipop (API 21) or Marshmallow(API 23) etc