Setting up Android Mode in Processing

I am trying to set up Android in Processing. But every time I try to load or download the SDK I get a message saying " The Android SDK could not be loaded". I have downloaded the Android 9 and 10 SDK from Android Studio.
Can someone help?

I had the same error, I resolved manually putting the sdk path in the preferences.txt file of Processing. Open preferences and on the bottom you should see the link to the file. Open it (while Processing is not running) and add this entry:


Hope this helps

download this extract it in any path then chose the path it self when processing ask for sdk

Which folder in the SDK did you put the address for ?

I downloaded the sdk directly in my Processing folder. So in the preferences.txt file I inserted this:


I tried this. But every time I start Processing the path address gets removed from the preferences.txt. file.


then select this path when you start processing android mode

follow this its is work with me

I tried this. But every time I add android.sdk.path to preferences.txt and open Processing, the path gets removed.

uninstall every thing and try again

i used just the folder without any thing from android studio maybe from your many trying you made conflicts cussed not finding the path first time i tried more than 14 days at last i install the folder on other pc that i have not run any sdk stuff or processing before it works fast without any issue then i re-installed windows on the pc that i tried also worked fine without any wrongs

do not add any text just chose the path

Too many attempts probably caused some problem. After uninstalling everything and reinstalling it worked properly. Thank you

1 Like