Android mode hangs on Android SDK notification

@noel @dinoelectro Well…nothing seems to be working for me, I’ve done all the things you guys said and I still get the same message, still can’t use the Android mode

@UnaLuz Sorry, can’t help any further because I don’t have a Linux ubuntu installed.
But you can still use the APDE app, Personally I don’t use the PC anymore for Android, All my work I do on a tablet.

@dinoelectro @UnaLuz @aabueno
I’ve simulated the problem by moving the SDK folder to another place.
Processing then asks to locate the file manually or let it download the file automatically.
I chose the last and really it gave me problems.
Then I installed Android Studio and actualized the SDK folder with the manager.
When I localized this file with Processing’s popup, it gave the same problem.
So I think it is a problem with the SDK itself.
When I localize my SDK folder (that I downloaded some months ago), all goes well.
I’ve zipped this android folder and upload it to my Google drive. You can download it here.
Just unzip it and place it in the Documents folder, to localize it manually as soon as Processing asks. I hope this will solve the problem.


Hey folks,

just registered, to contribute to this discussion:
For me auto-download also doesn’t work (Tested 3.5.4 and 3.5.3). I had this issue before, but the manual install via Android Studio usually did the trick, not this time.
It took me some time to find out, that I have to install “Android SDK Tools” separately and that (most importantly) this option isn’t directly visible: You have to uncheck “Hide Obsolete Packages” in Android Studio first to actually see the Tools install option -> see screenshot.

I hope I can help smn :wink:

My Setup:
Mac OSX 10.13.6 High Sierra
Processing 3.5.3 and 3.5.4


Omg thank you so much, I haven’t started to work with it yet but looks like that solved my problem. If anything else happens I’ll let you all know but for now, it’s working :smiley: