Wacatac trojan found in Processing Windows x64 download

Yesterday I tried to download Processing onto my new PC, only to have Windows tell me that Windows Defender had quarantined the Wacatac trojan horse in Processing’s core.jar file. I highly doubt the Processing Foundation would knowingly send its users malware, so I attempted to email the Foundation about the issue, but all I got back was a form letter sending me to the forums.

I don’t know if issue this goes in “Site Feedback”, but it honestly seems like a more important issue than a form letter can address. I don’t know how often the web team checks these forums, and I just made an account in order to post this. Has anyone else been getting infected downloads?


Related topic:

This has happed to me a few times before and I restore it after testing it.



Some of antivirus software do this while installing .jar files

Same happened while downloading installing Android Studio

That’s weird. I took a class on Android Studio a few months ago (though I was using a different PC then) and I didn’t have anything like this happen.

That said, I just tried to google “Wacatac” and one of the first searches that came up was “wacatac false positive”, so apparently this is a fairly common thing to happen? Thanks for the heads up on this, good to know the foundation’s servers haven’t been compromised.