Processing doesn't run my code

I have Processing 3.4 on Windows 10. When I press the run button, it doesn’t do anything. I tried running simple sample sketches with no result. I’ve had this problem before, but I just restarted my computer and it would start working. Now it doesn’t. Not sure what I am supposed to do.
Any suggestions?

1 Like

try reinstall processing?

1 Like

Take a look at preferences and select which display to run sketches on.
Actually go in and change display even if it seems correct.
I have had to do this before when my sketch was running in la la land.
Not had to do it for a while now though…


1 Like

Thanks for replying.
I tried to do this, but it doesn’t let change the display. It’s set to display 1 and it’s not clickable.

Try running manually with one of the “Sketch” tab selections.


1 Like

Unfortunately, still no results. :frowning:

I have 4 versions of Processing on my PC and they all work; sometimes code is “broken” with a new version and I have others to work with.

Consider doing the following:
0) Save anything and everything before proceeding. :slight_smile:

You must backup all your work!

  1. Delete Processing folder.
  2. Delete files in \Appdata\Roaming\Processing (in the preferences tab you can click on that)
  3. Reinstall. Try different versions.


I have had issues in past and have done the above.
You do so at your own risk .


hey, did you fixed the problem you had with processing 3.5.3??

i have the same issue