Programs not compiling anymore for ANDROID

I have been working with Processing 3.5.3 for a long time and developed several APPS for my smartphone using the ANDROID mode.
A few days ago, when I tried to compile a new Processing program, I got a lot of errors from the ANDROID compiler. Then I tried to load an exact program that I have working on my smartphone. It does not compile anymore, the compiler throwing the same lot of errors. Actually, i Got the same problem for any processing program.
Can anyone help with this issue please?
Thank you.

Here is just a sample of the messages:

Checking the license for package Android Emulator in C:\Users\mdnnv\Documents\Processing\android\sdk\licenses
Warning: License for package Android Emulator not accepted.
Checking the license for package Android SDK Tools in C:\Users\mdnnv\Documents\Processing\android\sdk\licenses
Warning: License for package Android SDK Tools not accepted.
Checking the license for package Android SDK Build-Tools 29.0.2 in C:\Users\mdnnv\Documents\Processing\android\sdk\licenses
Warning: License for package Android SDK Build-Tools 29.0.2 not accepted.

FAILURE: Build failed with an exception.

  • What went wrong:
    Could not determine the dependencies of task ‘:app:compileDebugJavaWithJavac’.

Failed to install the following Android SDK packages as some licences have not been accepted.
emulator Android Emulator
tools Android SDK Tools
build-tools;29.0.2 Android SDK Build-Tools 29.0.2
To build this project, accept the SDK license agreements and install the missing components using the Android Studio SDK Manager.
Alternatively, to transfer the license agreements from one workstation to another, see Sign in - Google Accounts

Using Android SDK: C:\Users\mdnnv\Documents\Processing\android\sdk

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at

org.gradle.tooling.BuildException: Could not execute build using connection to Gradle distribution ‘’.
at org.gradle.tooling.internal.consumer.ExceptionTransformer.transform(
at org.gradle.tooling.internal.consumer.ExceptionTransformer.transform(
at org.gradle.tooling.internal.consumer.ResultHandlerAdapter.onFailure(
at org.gradle.tooling.internal.consumer.async.DefaultAsyncConsumerActionExecutor$1$
at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(
at org.gradle.internal.concurrent.ManagedExecutorImpl$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
at org.gradle.internal.concurrent.ThreadFactoryImpl$


I had a similar issue a year ago or so.
I think I had to re-install all dependencies with either Android SDK or the Eclipse IDE so I could mark licenses as “accepted”.

That helped very much.
I deleted the whole Processing directory, installed the latest Processing version and added Android mode.
I run a simple sketch. During the Android compilation, the system automatically installed the emulator and accepted all required Tools licenses. The Android sketch run as expected.

Thanks a lot

I had the same problems. At least I remove All about processing from my computer and reinstall only the new version. When I put the android compiler, it loads corectaly everything and all works fine. when trying on another computer to have the two versions 3.xx and 4.xx, no problems on java version but impossible to generate android application (graddle error at compilation)

sorry for my poor english but french people are not very clever on foreign languages…


I had similar compiling issues few days ago. I think there is a problem with Processing’s SDK download script. I found a workaround installing required SDKs and command-line tools using Android Studio. You can find step-by-step instructions in my following post on Github.