Processing 4 on Raspberry Pi 4B - problems with Run, Present and Compile

I have been using my Mac version of Processing to compile executables for a new Raspberry Pi 4B. They work fine though a little slowly.

So I installed Processing on my Pi following the instructions on the Processing Downloads pages. It has been installed in my Pi Downloads folder. When I run it I can open and edit files (same as the ones on my Mac) but can’t Run, Present or Compile them. A huge number of errors are generated and most appear to be about missing Java components with unprintable names. I suspect that it has been installed in the wrong place?

Can anyone help?

Hi pbat,


Let’s have a look first:

Do you use specific libraries not installed or available on your PI.
Have a look if the built in examples are working.

If you already tried that, have a look for specific missing libraries.
Show us a screenshot if coed and error messages in addition.


Thanks Tom - it happens when I try to run the built-in sketches - like Flocking.

Here is a screengrab of the error listing - there’s another page - its too long for one grab.

The error message is “Could not run the sketch”

I’m on Raspberry 64 bit os and 64 bit Processing version 4.0b8 and it’s working fine.

Hi Tom - whereabouts on the Pi is your version of Processing installed?

I’ve extracted processing into

After running sudo it works.
But use the correct version, the 64-bit version of processing run on

Linux raspberrypi 5.15.32-v8+ #1538 SMP PREEMPT Thu Mar 31 19:40:39 BST 2022 aarch64 GNU/Linux

only. Check for the 64-bit architecture arch64.

pi@raspberrypi:~/Programs $ ls
arduino-1.8.19  eclipse-installer  java-2022-06  processing-4.0b8
pi@raspberrypi:~/Programs $ cd processing-4.0b8/
pi@raspberrypi:~/Programs/processing-4.0b8 $ ls  lib    processing       tools
core        java        modes  processing-java
pi@raspberrypi:~/Programs/processing-4.0b8 $

I definitely downloaded the 64 ARM version. I’ve run the terminal commands you mention and get this - there’s no mention of the ‘arch64’ term you refer to? I haven’t used Unix much since 1979 - so am pretty much lost here:

Could be an issue of 4.01?
Have you checked for the arch64 architecture.

So I’,m sorry I can’t help.

Does this help?

pi@raspberrypi:~/processing-4.0.1 $ file java/bin/java

java/bin/java: ELF 64-bit LSB pie executable, ARM aarch64, version 1 (SYSV), dynamically linked, interpreter /lib/, for GNU/Linux 3.7.0, not stripped

pi@raspberrypi:~/processing-4.0.1 $

Problem solved!

Even though the new Pi 4B is 64-bit the OS - Raspbian is only 32-bit. So I needed the 32-bit version of Processing and not the 64-bit one.

1 Like