Export an application for Raspberry pi 64 bit using video library


I want to export an application for Raspbian (64 bit) and run it on boot.
It exports perfectly for Windows and Linux (both 64 bit), and expected the same for Raspbian but it runs into trouble as it states the Processing 4 library does not support linux-aarch64 (see image that is attached).


However, when I run the code from the Processing 4 editor on a Raspberry pi 4 it runs perfectly fine, even though the console also warns about the library not supporting linux-aarch64.

Therefore my question, during exporting, is there a way to overrule this warning and export for Raspbian anyway? Thanks in advance!

Hi @Japser12,

Welcome to the forum!

I think you can use the processing-java executable in order to run your sketch from the command line (without having to build it):

$ processing-java --sketch=/path/to/sketch/folder --run

Hi @josephh,

Thanks for the reply!

I think this method should work indeed. However, when I try to run it via the command line I’m still getting an error: “bash: processing-java: command not found”

I have tried this but that does not seem to do anything. Have you got any ideas on how to fix this issue? Once again thanks for the help!

The processing-java executable is not added to your PATH by default. It’s located in the processing folder that you downloaded.

In my case it’s in ~/Downloads/processing-4.1.1 (where I downloaded Processing).

You can then provide the full path to the executable /home/johhnry/Downloads/processing-4.1.1/processing-java or add this folder to your PATH.


Thanks for the help!