Playbutton not working

Hi!
I can’t get processing 3.5.3 to work. Would anyone help me please?

It starts up, but hitting the play button doesn’t do anything except making the program (menus etc) react very slowly. This is with the only code entered being print(“hello”). After a while, red text appears in the console:

Traceback (most recent call last):
File “C:\Users\Michael Dmoch\Documents\Processing\modes\PythonMode\formatter\format_server.py”, line 3, in
import socket
File “C:\Users\Michael Dmoch\Documents\Processing\modes\PythonMode\mode\jython.jar\Lib\socket.py”, line 3, in
File “C:\Users\Michael Dmoch\Documents\Processing\modes\PythonMode\mode\jython.jar\Lib_socket.py”, line 217, in
at org.python.netty.util.concurrent.MultithreadEventExecutorGroup.(MultithreadEventExecutorGroup.java:88)

at org.python.netty.util.concurrent.MultithreadEventExecutorGroup.(MultithreadEventExecutorGroup.java:58)

at org.python.netty.util.concurrent.MultithreadEventExecutorGroup.(MultithreadEventExecutorGroup.java:47)

at org.python.netty.channel.MultithreadEventLoopGroup.(MultithreadEventLoopGroup.java:59)

at org.python.netty.channel.nio.NioEventLoopGroup.(NioEventLoopGroup.java:77)

at org.python.netty.channel.nio.NioEventLoopGroup.(NioEventLoopGroup.java:72)

at org.python.netty.channel.nio.NioEventLoopGroup.(NioEventLoopGroup.java:59)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)

at java.lang.reflect.Constructor.newInstance(Constructor.java:423)

at org.python.core.PyReflectedConstructor.constructProxy(PyReflectedConstructor.java:211)

java.lang.IllegalStateException: java.lang.IllegalStateException: failed to create a child event loop

The troubleshooting page (https://github.com/processing/processing/wiki/Troubleshooting) said to run it in debug mode from my console, here’s the launch4j.log-file:

Version: 3.9
CmdLine: C:\Program Files\processing-3.5.3\processing.exe --l4j-debug
WOW64: yes
Working dir: C:\Program Files\processing-3.5.3.
Bundled JRE: java
Check launcher: C:\Program Files\processing-3.5.3\java\bin\javaw.exe (OK)
Heap -Xmx: Requested 256 MB / 0%, Available: 3401 MB, Heap size: 256 MB
Substitute: EXEDIR = C:\Program Files\processing-3.5.3
Add classpath: lib\pde.jar
Add classpath: core\library\core.jar
Add classpath: lib\jna.jar
Add classpath: lib\jna-platform.jar
Add classpath: lib\antlr.jar
Add classpath: lib\ant.jar
Add classpath: lib\ant-launcher.jar
Launcher: C:\Program Files\processing-3.5.3\java\bin\javaw.exe
Launcher args: -Xmx256m -Djava.ext.dirs=“C:\Program Files\processing-3.5.3\java\lib\ext” -Djna.nosys=true -Djna.boot.library.path=lib -Djna.nounpack=true -Dsun.java2d.d3d=false -Dsun.java2d.ddoffscreen=false -Dsun.java2d.noddraw=true -classpath “lib;lib\pde.jar;core\library\core.jar;lib\jna.jar;lib\jna-platform.jar;lib\antlr.jar;lib\ant.jar;lib\ant-launcher.jar” processing.app.Base
Args length: 372/32768 chars
Exit code: 259

My Computer:
Lenovo T440s, 8GB Ram, Intel i5-4300U @1.9GHz 2.49GHz
Win 10 Home 64-Bit

1 Like

You are in Python mode?

You can change this upper right corner.

Try Java

But i would like to program in Python please?

on a win 10 / 64 bit /
processing 3.5.3 / 64 bit / mode python /
no problem ( play ready examples )

,


you have:

Win 10 Home 64-Bit

so you need to give more details about your processing
what you installed how…?
http://download.processing.org/processing-3.5.3-windows64.zip


also please answer @Chrisir 's question:
does in JAVA Mode

  • any example work?
  • a graphic demanding example also work like “ribbons”

for reinstall must delete
ALL 3 Processing dirs.
see also
Processing isn't running (java.lang.NullPointerExcpetion) ;


1 Like

Hi kll and thank you!

so you need to give more details about your processing
what you installed how…?
http://download.processing.org/processing-3.5.3-windows64.zip

Yes, i installed it by downloading that file and extracted the content in to my program files folder, then ran the processing.exe that is in there.

for reinstall must delete
ALL 3 Processing dirs.
see also
Processing isn’t running (java.lang.NullPointerExcpetion) ;

Thank you, indeed i wasn’t aware processing creates more dirs on 1st startup. I now deleted all dirs and installed freshly, but that didn’t change anything -.-

does in JAVA Mode

  • any example work?
  • a graphic demanding example also work like “ribbons”

Ok, i switched to Java and tried a simple print(“hello”); as well as the ribbons example. The same error occurs in both cases, just like with the python mode.

1 Like

Hey @Chrisir,
sorry i misunderstood your post as a solution by just using Java instead of Python. Now i understand you wanted to know if the error occurs in Java, too. I can only apologize.

1 Like

that seems not possible,
in pure JAVA Mode the python jython.jar does not even exist
( and would never be called )
the error after

  • fresh install processing and
  • starting a existing example
    must be different ( then what you see in python Mode )

so if processing not run at all on your computer
from any other reports here i only can guess that the graphic driver
not fits. ( no better idea )

  • %ProgramFiles% is an OS restricted folder.
  • It’s meant for apps which are installed via an installer.
  • Both Processing’s Windows & Linux versions don’t have an installer.
  • So it’s recommended to extract Processing somewhere else.
2 Likes

@GoToLoop, it sounds good,

but a test here on a win 10 64bit and

  • copy from

    • c:\Users\ < USER > \Documents\processing-3.5.3\

    to

    • c:\Program Files\processing-3.5.3\

with admin priv.

  • and start from there
  • YES to allow JAVA
  • run a existing JAVA sketch ( as system dir and sketch dir not changed )

NO PROBLEM
well, could be different with a new install or python or non admin user …


sorry i just not find the official

1 Like