No display on Windows, many student problems, any thoughts?

Dear all,

I just deployed Processing to a class of 48 students. I have a lot of students with issues where their sketches will apparently run, but no drawing will appear. I have not yet had a chance to see this happen; we had zero problems in-class on Thursday, but a number of problems manifested over the weekend.

We are attempting to use Py.Processing. Perhaps it is not ready for prime-time?

Either way, I know students have problems on Windows 10/64-bit, but I couldn’t possibly go further in providing information at this point. I know they all downloaded Processing within the past week, so they are current. However, I don’t know what other issues there might be that I need to try and diagnose.

I would welcome either 1) pointers to solutions, or 2) recommendations to abandon Py.Processing. I chose Py.Processing because many of my students have seen Python before, and the consistency of experience was what I was going for. If I jumped without looking closely enough, I could consider switching to… p5.js?.. and have an in-browser experience (and, thus, perhaps get consistency across platforms)?

Thoughts welcome. I have class tomorrow at 8AM, and expect to face some frustration. Suggestions welcome.

1 Like
  • I’ve always been able to run Py Mode since WinXP.
  • And I’ve got it running now on this Win8.1 laptop for a long time.
  • However, I’ve recently installed Win8.1 on a desktop PC.
  • Almost nothing is installed on it but Steam and drivers.
  • Well, I still hadn’t Processing on it yet and decided to install it just now.
  • And for the 1st time, Py Mode ISN’T working at all!
  • I hit play and NOTHING happens for any Python sketch, be it correct or buggy by purpose!
  • Even disabling the firewall has no effect either!

I experimented with pyprocessing some years ago it worked OK but was rather slow, but it did have a advantage of being regular python. Even if current problems get ironed out for python mode for processing, there is a potential problem in that jython does not seem to be actively developed. I have been rather more fortunate with jruby (actively developed) that I use for JRubyArt.

1 Like

confirm processing 3.4
new install Python mode

Python Mode for Processing 3 3049

run not show any canvas

  • win 7 pro SP1 / 64bit
  • RPI Raspbian linux

Somehow you gave me the idea to copy my laptop’s “PythonMode/” folder to my desktop PC. :bulb:
And it just worked after that! :partying_face:

Seems like even though PDE’s Contribution Manager says it’s gonna download Python Mode build 3049, it actually downloads build 3050! :crazy_face:

Just checked that build 3050’s “PythonMode.jar” file was compiled by Java 11. :coffee:
AFAIK, Java 11 is still incompatible w/ current PDE! Needs to be at most Java 8. :expressionless:

1 Like

I’ve uploaded build 3049’s “PythonMode.jar” file to this repo below: :link:

In my tests, by just replacing build 3050’s “PythonMode.jar” file w/ build 3049’s was enough to make it work. :money_mouth_face:


Many thanks, @GoToLoop. Normally I don’t download random .jar files and distribute them to my students, but you’ve got a sweet bike in your Github profile image, so you must be trustworthy. :smiley:

I really appreciate the rapid look into this, and I will report back after I try the .jar replacement with a few of the students. If it works, it is worth filing as a proper bug against the repos, I would think.


Alternatively, you can grab the “PythonMode.jar” file from 1 of your students who got a workable Python Mode. :wink:

Good point! :slight_smile:

Again, thank you for your .jar. We successfully applied it to a Windows Surface machine, and to a Mac running Mojave. I know there’s still a few more out there who had problems and will be applying the fix, but it looks like it eliminated the critical issue we were having. So, again, thank you.

Next, I have to work with IT on firewall issues on the campus desktops, but we know why that is a problem, and how to fix it.


1 Like

thanks for the update,
i try
win 7 / 64 bit && processing 3.4 64bit
install python mode and see that confusing info:
it downloads 3049

and installs 3051

but it works well now.


Just popping in to say thank you to @GoToLoop and report that this solution still work, at least for OSX 10.2.6. You can find more information about the issue here but was last updated Sept. 24, 2018.

Java 9 includes major changes to how the VM interacts with the OS, particularly on macOS.

At the moment, it’s likely not even possible to use Processing with Java 9 or later, due to several internal changes that break Processing libraries or the PDE itself.

That doesn’t explain why most people are not having this issue, but there’s a lot of unexplained things when your code works (and the universe in general) so it’s a shoulder shrug on that one.

The link @GoToLoop provided has since been removed in a commit but if you go back in the commit history you can download it here.

Then as @GoToLoop said, simply go to:

Processing >> modes >> PythonMode >> mode

And replace the current PythonMode.jar with the one @GoToLoop made.


Funny timing, the Java 11 issue was just closed a few days ago and moved to the experimental development fork for Processing 4.

1 Like

Hi, sorry to reopen this thread but I clicked on the GitHub link and I can’t find py. 3049 in there.

I too own a Mac and am having issues finding the display window.

Read @crld’s finding below:

Just be aware that the most current Python Mode version for PDE 3.5.4 is build 3063.

I tried this download but my Mac won’t allow it to be opened. It says it can’t identify that it is not malware.

@lei10003 – see section “If you want to open an app that hasn’t been notarized or is from an unidentified developer”