I cannot change Sketchbook folder

I change the Sketchbook folder in Preferences and the default one (C:\Users{username}\AppData\Roaming\Processing) always comes back!

Can anyone tell me how to change Sketchbook folder in Processing 4?

Thank you.

1 Like

Hi and welcome

Thank you for your prompt answer!

Also when upgrading from P3 to P4, take extra care not to use the same “SketchBook” folder being used by P3 on P4.

Choose or create another “SketchBook” folder for P4 so P4’s new libraries won’t corrupt P3’s!

I did exactly what the reference said, changing ‘preferences.txt’ as needed.
Nope! The default folder (C:\Users{username}\AppData\Roaming\Processing) is still there! Which means that ‘preferences.txt’ is ignored.

It’s really unbelievable for such a sophisticated S/W to stumble on such a simple and basic issue, a customary action that so many programs in the history of PCs have adopted since 40 years ago!

File "%AppData%\Processing\preferences.txt" is where Processing looks up its configuration.

Among them we have properties such as these 3:

  • sketchbook.path=
  • sketchbook.path.three=
  • sketchbook.path.four=

Which determines the each “Sketchbook” path for Processing versions 2, 3 & 4 respectively.

Again, have utmost care when upgrading Processing to a major version, as not to mix those paths!

Otherwise libraries, modes and tools will conflict w/ each other due to major version incompatibility!


If you have issues saving preferences…

The issue is discussed here:

I save my preferences as noted in the issue above:

  1. Change some other Preferences
  2. Close the preference window using the “Ok” button at the bottom of the preference window
  3. Close Processing using Menu Bar → File → Quit or by pressing Ctrl-Q
  4. Restart Processing
  5. You should see in Preferences that this time everything has been updated.

The above works for me on W10.

Processing 4.1.2 is now available:


Both the issues I reported (changing Sketchbook folder and installing Python mode) are solved very easily and as expected by installing version 3.5.4. The solution was offered by @tabreturn (I cannot add Python mode! - #9 by Alkis).

Thanks a lot to everyone who contributed! :pray: