Help not opening until PDE exits

Hi all. I just updated to processing 4.0b8 some weeks ago.

If I use /help/find_in_reference or /help/reference menu entries nothing happens. Nor firefox opens, nor window or tab in firefox opens. But if I exit PDE then a window or a tab opens with the instruction previously selected (for find in reference menu entry) or just the reference index (for reference menu entry). Need to say: I get an unable to conect error since the server on port 8053 is not longer running, restarting processing gives the same error. Restarting firefox is how I can get the page even if PDE is not working! Of course, if I hit the reload button i get again the “unable to connect” error page.

Also I would like to know why a local server is launched for help when the usual file:/// method worked so well. I think this has been discussed somewhere, but has been unable to find about that.

Oh!! And just found something else. Just launched processing 3, it uses the file:/// method and help is opening after I exit PDE.

My system is fedora 36 with mate desktop environment.