Processing won't start. An unexpected, unknown, and unrecoverable error ocurred

Hello, I’m having a weird problem.

I’ve used Processing on many computers now, but this is the first time I encountered this.

When trying to run the .exe on this computer it just won’t start. I get this window with the title “Serious Problem” and then it says: An unexpected, unknown, and unrecoverable error occurred while opening a new editor window. Please report this.

After that there’s a very long log stating that some java bundle couldn’t be found. I first had this problem with the latest version of processing, 4.2, so I tried downloading some previous Processing 4 versions, but the problem remained the same.

I then tried with the 3.5.4 version and while I don’t get the error window, now the Processing launching/welcoming window appears for a few seconds and then it closes, and nothing else happens.

I attached a screenprint of the error log.

If I need to share more info to help you help me with this please tell me.

Hi @Abraham,

Welcome to the forum! :wink:

The best way to post a bug report is to copy the text in your message by using the code blocks (</> button or wrap it with backticks like so: ``` code ``` → code) instead of putting a screenshot of the logs (hard to see by the way).

Also you can see if there’s a similar issue on the Processing 4 GitHub repository:

That was my intention, but the error log didn’t allow to copy the text, I actually don’t even know how long it was, as there was no way to resize it or move it easily… Thanks, let me read the issue in the repository, hopefully it helps.


Ahh my bad, it’s strange that you can’t copy it…

We should make an issue about the fact that it’s difficult to report when a “Serious Problem” happens.

Can you try launching Processing from a command line prompt (CMD in Windows)?

  • Launch Cmd (in the windows application search bar, search cmd)
  • Type cd <processing-folder> where <processin-folder> is the folder where the executable is located.
  • Do ./processing.exe and see the output result

The relevant code is here:

(I don’t know if a JOptionPane text can be selected thought…)


Found a solution here: java - Selectable alternative to JOptionPane.showMessageDialog - Stack Overflow

1 Like

I tried launching from the CLI and got the same error.

Reading some other issues on the repo I got the idea to create another account on the same pc and trying to run processing on that account.

To my amazement, it worked just fine.

So there seems to be a problem with this specific account, at some point some key files must have gotten corrupted or something. And while I can technically use processing now this isn’t a solution but a workaround, but at least it’s something.

Thanks for trying, if you got any more ideas I could try please tell me.

1 Like

All right!

Can you post the GitHub issue you are referring to?

1 Like

It was issue #549.

Here’s the link

Just by reading the title (OP says processing wouldn’t start for a second user in an Ubuntu machine) I got the idea that maybe on another account it could work. Their error wasn’t the same I got, although, it was still another “Serious problem”.

As I said, the new account does not have any problem running processing.

1 Like