Having an issue running Processing

I don’t use forums to often and i’ve never used this forum so i apologies in advance if i make a mistake in the rules.

The issue is when i run processing i get the normal loading screen,
How ever, i am then greeted with this error screen:
Screen Shot 2020-06-04 at 9.31.21 am

I am running it on a mac OS, i have had processing for a long time, but i haven’t run it in a good half year.
Any help would be greatly appreciated, thank you.

1 Like

Hi @Sand_Echidna
Just a guess.
Go and find the preferences.txt file of the Processing’s ide (with the app closed)
The path on Windows it’s something like “C:\Users\YourAccount\AppData\Roaming\Processing”
Search for a string like " examples.processing.app.ui.ExamplesFrame.visible=null\Contributed Libraries;null\Contributed Libraries\ImageLoader;null" or any other string that contains the string “Contributed Libraries” and delete it. Save the file and restart the ide. If it starts well, cheque the Contributed Libraries in “Add tools” menu, to see if everything is in order.
You may also delete the file “contribs.txt” (where the libs are listed) in the same folder, with the ide closed, and than do a restart.


I fixed it, i just deleted every file relating to processing that i could fine and saved all my old programs in a backup folder, i then reinstalled processing again and put the programs back in and it managed to work.
thank you still @noel for trying to help, but i took the lazy option.