macOS processing unable to start "we're off on the wrong foot"-Solved

I have been using it normally before, but suddenly something went wrong yesterday. I checked a lot of previous topics, but still can’t solve this problem.I don’t understand deeper principles, but I haven’t found a solution for a long time. Hope you all help me, thank you very much.

Processing 3.5.3
macOS Catalina 10.15.2

I found the solution!
Processing won’t start up(using OSX Mavericks,Many thanks to the author of this article.
Solutions (macOS)

  1. Open Finder and execute shift + cmd + G, type ~/Library/Application Support ,click ok.
  2. find the “processing” folder here and delete it.
  3. finally download and start the latest processing

thank you for reporting,
may i ask back ( i do not have that hardware/OS )

~/Library/Application Support/Processing

the macOS folder what holds


? so it would be comparable to ( what i call processing system folder )

c:\Users\ < User > \AppData\Roaming\Processing\

for windows?


for Raspberry Pi.

1 Like

Sorry, I did n’t indicate macOS in the “solution”.
At present, I only encountered a problem on macOS, so I do n’t know how to solve it on the window system.
I think the core of the problem is the errors in the file preferences.txt .

1 Like

I just upgraded to Catalina OS X 10.15.3 and Processing Crashes. Followed instructions above and couldn’t find a folder called Processing in Application support. Tried installing Processing a few times (out of desperation) and crash crash crash. Any ideas?

In this case, reinstallation really doesn’t work.

Try this: search for “Processing” (there should be multiple files with the same name);
2.turn it on and see if there is “preferences.txt” inside;
3.locate preferences.txt, then delete; processing (it should open normally at this time);

When you reopen processing, you automatically recreate preferents.txt in the installation directory.
I hope I can solve your problem.


Thanks for your response (yes I do realise reinstallation shouldn’t work but …) anywayit started to work after several reboots of the os - this is weird behaviour.