fullScreen(2) still opens on primary screen


I have a bunch of sketches with fullScreen(2).
When I run the sketch it opens on my primary screen, not the secondary one. I’m on a Mac powerbook. I tried plugging/unplugging the other monitor, restarting, etc. Nothing is working.

I feel like I’ve had this problem before, but I don’t remember how I overcame this.

Any suggestions are appreciated.

Thank You

if you are extending your screen, maybe by simply dradding your Processing window into your second screen it should work ?

Hi Pr0tonX.

I tried that and it didn’t work. I was using a projector recently and everything was fine. I don’t think I changed any settings. Now I am using a 2nd monitor and my sketches only open on the primary screen regardless of where I drag my sketch.

I just tried fullScreen(P2D, SPAN);

and I got the following error:

Could not check the status of “Displays have seperate spaces.”
Received message ‘2020-01-13 12:08:58.013 default [853:33321] The domain/default pair of (com.apple.spaces, spans-desplays) does not exist’ and result code 1.

I’ve never used span before, but just trying different things out to trouble shoot this. I don’t know if it’s related, but seems like Processing can’t access the other screen, but my computer definitly can and I can drag things back and forth.

OK. Very Strange. I plugged my HDMI dongle into another USB C port on my computer and now the 2nd screen is working. I still would like to figure out what’s going on, but for now everything seems OK.