Fatal error on trying to load program

about a year ago I used Processing to open DCC++ software. It worked fine
A week ago I tried to open the same program and get an immediate error
“an unexpected, unknown and unrecoverable error occurred while opening a new editor window. Please report”
I have downloaded version 3.4 (previously 3.3). exactly the same
I downloaded the DCC++ file again with no change…
I might add that my DCC++ system does not seem to work either but i think i have traced this to a failed arduino uno

Any advice please would be appreciated


Well, if it isn’t a change in your operating system, then best guess is that it might be a change in Processing?

Though this code base is relatively mature and has been tested with the latest version of Processing (3.0.1), it is not as well-commented or documented as the DCC++ Base Station code for the Arduino. GitHub - DccPlusPlus/Controller: DCC++ Controller for Processing IDE

So you could try downloading Processing 3.0.1 to see if that works. Otherwise – did you upgrade your OS?