Encountering bugs in Processing 4.1.1 on Windows 11

I have been using Processing 3.5.4 for a while but yesterday I decided to download Processing 4.1.1.
I found a couple of bugs that are mostly just really annoying. I have read around online but have not found them mentioned (or solved) anywhere.

I found the following bugs/issues:

  1. There are no modes in the modes list.
  2. Most values in the settings don’t get saved when changed. (eg: Sketchbook folder and Sketch name) But some do (like Disable HiDPI Scaling and Language)
  3. Some times (but not always) after closing the settings, the File menu becomes un-clickable until the size of the window is changed

I have made a video demonstrating all of these issues, you can see it here

Steps I have taken:

  • I first moved the folder containing processing to a new location with less restrictions
  • Next I moved the folder to the desktop, just in case
  • I deleted the folder and all settings and other stored files, re-downloaded 4.1.1 and extracted it on to the desktop
  • I downloaded 4.1.0 and 4.0 and tried both of them
  • All of these I added to the Microsoft Defender exclusions list
  • I turned off Microsoft Defender and all real time protection
  • I ran 4.1.1 in administrator mode
  • I ran 4.1.1 in compatibility mode
  • I ran .\\processing.exe --l4j-debug. I attached the resulting log file below
Version:		3.14
CmdLine:		C:\Users\radic\Desktop\processing-4.1.1\processing.exe --l4j-debug
WOW64:			yes
Working dir:	C:\Users\radic\Desktop\processing-4.1.1\.
Java min ver:	1.017.000_001
Java max ver:	
Bundled JRE(s):	java
Check launcher:	C:\Users\radic\Desktop\processing-4.1.1\java\bin\javaw.exe (OK)
Heap -Xmx:		Requested 512 MB / 0%, Available: 985 MB, Heap size: 512 MB
Main class:		processing.app.ui.Splash
Add classpath:	core\library\core.jar
Add classpath:	lib\pde.jar
Add classpath:	lib\jna.jar
Add classpath:	lib\jna-platform.jar
Add classpath:	lib\ant.jar
Add classpath:	lib\ant-launcher.jar
Add classpath:	lib\flatlaf.jar
Launcher:		C:\Users\radic\Desktop\processing-4.1.1\java\bin\javaw.exe
Launcher args:	-Xmx512m -Djna.nosys=true -Djna.boot.library.path=lib -Djna.nounpack=true -Dsun.java2d.d3d=false -Dsun.java2d.ddoffscreen=false -Dsun.java2d.noddraw=true -Dpython.console.encoding=UTF-8 -classpath "lib;core\library\core.jar;lib\pde.jar;lib\jna.jar;lib\jna-platform.jar;lib\ant.jar;lib\ant-launcher.jar;lib\flatlaf.jar" processing.app.ui.Splash
Args length:	343/32768 chars
Exit code:		0

Additional info:
I’m running Processing 4.1.1 on Windows 11 Pro x64 22H2 Build: 22621.900
CPU: Intel(R) Core(TM) i5-10300H CPU @ 2.50GHz 2.50 GHz

As I was writing this, I found a weird solution/workaround, that may help identify the issue.
As you can see on the video, if I change a setting, save it, exit Processing and than start Processing again, the setting will not be saved.

However, if I change a setting, save it and than instantly open a second instance of Processing, that instance will use the new value for the setting, and it will work like that from that point onward.
This though still doesn’t solve the issue with the modes.

I’ll happily provide any additional information that helps!

I found a workaround for the modes as well.
I downloaded 3.5.4 again, and downloaded python mode on that one. As soon as I opened 4.1.1 again, I found that python mode was now available there as well.
This may help a little until this issue is solved.


Hi @WolfyD Thanks for reporting this in such details!

The issue with preferences has been reported here. Feel free to add any missing information in the replies.

As for the problem with modes, would you mind raising this issue on Github so it can be investigated?

1 Like

Hi @sableRaph Thank you for the quick response!

I will check the GitHub page, thank you!
And sure, I’ll create an issue for it.

1 Like

Hello @sableRaph
I created a new issue in GitHub.
You can find it here

1 Like