Daylight robbery

i tried downloading processing 2.2.1 as i need it for my older projects. It just wont allow me to go anywhere without giving a donation. after a lot of tries i finally gave up and gave a 5 dollar minimum donation. inspite of that the software wont donwload! . first forced donation is daylight robbery and then u have the audacity to force me to get the latest version …

this is ridiculous please fix ur website !

What web browser are you using? And are you using any ad blockers or shields?

I am really sorry to hear this.

I tried it, Download starts automatically on the donate page without you have to donate

Yeah, maybe you have a blocker.


What link / OS do you need?

1 Like

thanks for your prompt reply. I can download all versions except the 2.2.1 version. It simply takes me to the donation page. Can you please send me the download link for 2.2.1 macosx version .

i am using chrome browser.

thanks again.

Instead of ranting at people who freely give their time to develop Open Source software for other people (you included) to use you could try learning to use a search engine!

All versions of Processing are mirrored on GitHub here: Tags · processing/processing · GitHub
and can be downloaded without having to go through the Processing website. 2.2.1 is there, I downloaded and used it yesterday.

1 Like