Can't start Processing 4 macOS Big Sur

I’m working on a MacBook Pro with MacOSX Big Sur. I can’t start last version of Processing 4 as it shows me a message saying “We’re off on the wrong foot” (see picture attached).

I have modified read/write permission fot /Users/rubenbigsur/Documents/Processing/modes allowing everyone to read and write, but the same window appear if I try to restart Processing.
What can I do?
I tried to fix it as it’s described in macOS processing unable to start "we're off on the wrong foot"-Solved but the problem persists.

I don’t know what’s happenning. The only fix that I have found is uninstall Processing and install it again. Before running, I have to delete the /Documents/Processing folder. Then it works till I close it. When restarting, the same error window appears.
I’m working on a MacBook Pro intel i7 based laptop.
Don’t know what to do.

1 Like

Hi @Smantik, I’m sorry I don’t have a solution to offer but would you mind opening an issue about this on the Processing4 Github?

Ok, Raphaël. I’ll do.

1 Like

Hi, @sableRaph . I have found a solution. The last time I have reinstalled Processing, deleted /Documents/Processing folder and restarting, Processing tells me that there is no Processing folder and that is going to create it.
After that, I opened /Documents folder, and modify /Processing folder permission for letting everybody read and write. Then, I opened /Processing folder and changed one by one the permissions for every subfolder in the same way.
Now I cant close and start Processing perfectly.

The problem has been resolved for me. Do you think that I have to open an issue on Processing4 Github anyway? Perhaps some people will have the same problerm.


Yes I think that would still be useful. It’s great you could find a solution but it sounds like something that should not happen to begin with.

1 Like

Ok. I’ll do. Thanks, @sableRaph

Today, the message appears again when starting Processing.
So, this is not a valid solution.