Can't import AWS library

I’ve been trying to work this out for a few days, but I’m starting to give up… How do I import and use the Amazon AWS 2.0 SDK in Processing?

I want to use Amazon DynamoDB to be able to have a few variables (highscores, number of plays, etc.) for my game in the cloud. I originally was going to use a Raspberry Pi I have, but then I found out Amazon provides some DynamoDB use for free, and decided to use that.

I’ve tried just downloading the jar and dropping it in the Processing window (for it to be added to the “code” folder), using Maven to build the part of the 2.0 SDK with DynamoDB from CMD, and then putting the generated folder in Processing’s libraries folder (Although I wasn’t sure exactly what to put there, I tried a few combinations of everything, just the jar, a src folder…). But when I get to the step of, in Processing, writing the import com.amazonaws.*; it just tells me the library I’m trying to import doesn’t exist… This was my latest folder sctructure attempt: Folder structure attempt.

I’d really appreciate any help, I’m really new to this, and can’t find any tutorials specifically about doing this in Processing! I’m happy to give any details needed. Thanks!

1 Like

Solved thanks to a really helpful person on StackOverflow, link here if anyone has the same problem: https://stackoverflow.com/questions/60122736/can-t-import-aws-library-to-processing?noredirect=1#comment106336989_60122736

3 Likes