Big Sur and new Macs

Hi all,

Wondering if anyone willing to share initial experiences with Processing on the new Mac hardware and “Big Sur” OS11 (OSX 11? OSXI?) … For context, we have a number of semi-permanent and permanent installations that use Mac minis and run Processing/Java full-out, thousands of threads, 24/7 type things, and sometimes require external hardware like sound cards etc. Wondering what kind of change we should be prepared for if we start using the new silicon and operating system. Catalina had a few things re: security, and access to peripherals, but we managed.

Anybody taken the plunge yet? (I know the hardware is only out today, but dev previews have been around for a bit)

Thanks,

I get a blank screen when run. Creating a movie gives the proper tiff files, just cannot see from the screen what you are getting.

Currently it seems Azul “Zulu” builds might be the way to go on jdk front, but you are likely to be missing OpenGL support and a lot of other hardware related stuff see link to @headius tweet (aka Charles Nutter chief JRuby developer):-
`

It is worth
pointing out that the sources for the Azul “Zulu”
builds of OpenJDK are largely the same as other organizations’
builds of OpenJDK, so I would expect those JDKs to work just as well
when they are available and supported! https://t.co/Oa7FVEd16d


Charles Nutter (@headius) November
16, 2020
`

See Also http://openjdk.java.net/jeps/391, support will likely only be available for jdk11+ so you are looking at processing-4, so 1st step would be to try out the beta version…
There will be major if not crippling issues with using rosetta software.

2 Likes

That worked. The screen is visible with Processing 4 alpha.

1 Like

A blank screen while using processing on Big Sur happens on older machines as well, not just M1. For myself it affected P3D programs.

A user on the Github site has indicated that including frameRate will let the screen display normally. I have tested this with several P3D examples myself.

2 Likes

thanks for the followup