Problems with P2D and P3D renderers with new Apple M1 processor

I have encountered an issue when trying to execute sketches that function and export correctly on an older MacBook Pro when these sketches are attempted to be run on a new MacBook Pro using a new M1 processor. I have tried to use two different versions of Processing. 1) the stable 3.5.4 release (17 Jan 2021) and 2) pre-release 4.0 alpha 3 (17 Jan 2021). Both appear to have similar issues.

The sketches fail - i.e. they only open a blank window and the following is displayed in the console:

0   AppKit           0x00007fff22c308bf -[NSWindow(NSWindow_Theme)_postWindowNeedsToResetDragMarginsUnlessPostingDisabled] + 352
1   AppKit          0x00007fff22c1b561 -[NSWindow_initContent:styleMask:backing:defer:contentView:] + 1375
2   AppKit                              0x00007fff22c1affb -[NSWindow initWithContentRect:styleMask:backing:defer:] + 42
3   libnativewindow_macosx.jnilib       0x000000012a7883fe Java_jogamp_nativewindow_macosx_OSXUtil_CreateNSWindow0 + 398
4   ???                  0x000000010eed84c8 0x0 + 4545414344

but, experimenting with some of the simple Processing Examples, I noted that if I add a

  size(900,600,P3D);
  frameRate(30);

a “frameRate” command immediately after “size” that the sketch executes and runs correctly in the IDE.

So that is positive, but if I then try to export the sketch as an application, the exported app is created but it fails when you try to run it.

So, based on the comments in:

it appears that there remain issues with the Processing IDE and the M1 processor.

I am curious is others have had these problems and if based on the comment in the github

  • Haven’t had a chance to test much with macOS running on M1 machines. Chances are this should run in Rosetta mode, but I’ve not had time to find out."

anyone has tried to install the Rosetta mode on a MacBook Pro with the M1 processor with success in resolving these problems?

There are jogl binaries for ios-arm64 at the jogl deployment archive, they might be worth experimenting with?

Thank you for the suggestion. I will explore this option.

I am assuming that there will be more Processing users that will encounter this issue as more M1 processors are sold, so hopefully it can be resolved within the IDE in the near future.

Thanks again for your help.

1 Like

A Solution of sort. With some assistance from the Forum and a bit more research, I think I have an idea as to the cause of this issue and what will eventually be need for resolution.

A couple of other forum members have also encountered the same issue when using a Processing on a Mac using the new Big Sur macOS 11.1.

  • Sketches with P2D and P3D renderers do not run in the IDE unless the frameRate (xx); command is included in setup.
  • Those sketches do run correctly in the IDE if frameRate() is included but will not export into an application that will run.
  • This occurs with both the new Apple Silicon M1 processor and the 4.2 GHz Quad-Core Intel Core i7.

So this issue appears to be the result of the new macOS 11.1 and since the current stable release of the Processing IDE for the Mac is 10.13 - those who have or plan to acquire a new Apple product that will use the OS 11.1 - may encounter this issue and hopefully a fix will appear in the 4.0 version of Processing is released.