Does Processing work well in Mac M1

Does Processing work well on Mac book with M1 processors?
Any known issues?

Hi @Vrishy ,

Welcome to the forum! :wink:

You can check the previous threads on the subject related to M1 :

hi,
i use processing on M1 since 2 months now…
Transition was better than expected, but some behaviours are strange:

main caveat so far, i was not able to export: sketch run from ide as expected, but it fail on export,
however if you export the code on another machine, the app created will work on M1

all examples from processing works well, with both processing 3.5.4 and processing 4,
only ones related to webcam via video library fail, (library still works for playing movies )

i didn’t expect but ps3eye library works, didn’t try kinect library yet

i was surprised even low level opengl calls, all glsl shaders , jocl calls works well, and all other external libraries i tried so far, opencv, xuggler, irods…

but some stuff feel not totally stable, for eg, “save as” behave strangely : sometimes only a part of the files are duplicated
it’s strange but behaviour became more smooth after few days,
first days i had issues of security prompt asking about directories permission randomly for same directories (i think it s big sur related problem more than M1 ) or sometimes it tooks 30 sec to get a windows when you press run

and with huge sketch, sometimes processing just hang 3 minutes with 500% cpu, then is back to normal
this too happened less and less after few days… (some rosetta learning curve??)

while software is running, cpu usage vary more than it was on intel macbook pro, still…it s really faster for heavy data manipulation, and faster for heavy visualisation (volume rendering)

some benchmark from processing performance examples:
quadRendering 65fps
dynamicParticlesImmediate 280 fps
dynamicParticlesRetained 190 fps
textRendering 50fps

plug in and unplug external screen while a sketch run can result in strange behaviour

ha and last, as someone find out in this forum, you need frameRate(xx) in setup to run P3D sketch, otherwise you got a blank windows

it sounds lot of issue but for my personal workflow i still had a huge gain, i never had a so huge improvement between two mac generations…

Tell me if you need some more specific test… or to test your project before switching…

2 Likes

Hi, are they any plans to create at ARM version for processing 4.x ?

I fell pian, when I run my favorit software in migrating mode. So much money for nearly the same speed.
Best regards Gerd

Hi all,
Any updates on this topic by March 2022? It seems the previous responses are at least 1 year old.
Do we have Processing working well under M1 processors already, or is it still the same?
I need to upgrade my macbook pro and I am very hesitant to make the switch due to this.
Cheers

hi,
one year later… i will say it work well, i don’t face any of the issues i pointed last year,
last versions of processing export for both mac architectures aarch64(arm) and x86-64(intel),both works well, with P3D sketch it run from the ide, and x86 exported app works too but not the aarch64 exported apps. however , running x86 version app via rosetta have really good performance.
i updated a lot of my sketchs and all are fine…
if needed i can test some of yours…

1 Like

Thanks a lot! I might still wait a while to upgrade my machine as I need to check other software as well, however good to hear things are progressing well. Will get in touch again if needed for testing, sure :sunglasses::+1: