Audio in problem with Mac OS Catalina

Has anybody else encountered problems with getting the built-in mic to work with Processing with a new OS update? Same patches were working fine until I upgraded to Catalina. Somehow Processing can’t access the microphone. Is there a solution for this?

My guess, is that with every update macos gets more “hidden” security features. Go to System Preferences>Security>Privacy and ensure Processing can access the mic.

I tried that but Processing does not appear as an option there - and I don’t know how to add it there. Perhaps via Terminal - But I don’t know how.

Are you connecting an external microphone or device to your system or trying to use the internal microphone?

Hi Svan - trying to use the internal. I haven’t tried with external audio device - will check that tomorrow. But just wanted to check with the internal mic if it worked. Some old patches using audio in to trigger graphics just didn’t work anymore because of that.

Are you able to see the internal microphone in SystemPreferences/Sound/Input? The only way I see anything to select is to plug in an external microphone; internal microphone is not even a choice. According to this URL some models don’t have one:Change the sound input settings on Mac - Apple Support

I’ve found a workaround that was suggested by another person on the forum:

It involves: opening the Processing 3 app through Terminal by typing:
Then opening the file needing mic access - this triggers the pop-up asking to access camera and mic and then it works…
Hopefully there will be a simpler solution in the future…but this works for now. See the github post where this was mentioned: