Android mode install issue

I’m trying to install Android mode on my new windows 10 notebook. I’m receiving an “android sdk could not be loaded” error. I moved the sdk from my previous notebook and manually pointed to it but running the sketches, which worked on my previous notebook, in the emulator which fails with a standard known message. I tried deleting everything except the sketches and reinstall but I get the error message i previously mentioned. also, the pde erased my previous sdk install. The web and forums suggest installing Android Studio, but why? I’ve never had to do that before. It seems excessive. Also, the Processing foundation never mentions needing Android Studio to get Processing Android mode to work. Anyone have any ideas? Thanks

The web and forums suggest installing Android Studio, but why?

Android Studio contains the sdk that it uses.

Try the following; Download this SDK folder and unzip it in the documents/processing folder or elsewhere. Then open the preferences.txt file. The location you can find at the bottom of the File/settings menu.
In the android parameters you will find something like:


Change/set or correct the right sdk path as where you saved it.
Save the preferences.txt file with the processing’s IDE closed
Start ide again.


Scan, Android studio contains the sdk that Android studio uses and Processing 3 could use, but processing 3 can and has its own sdk to download. I’ve done so on at least 5 PCs. But it seems as if the latest windows 10 update 1909 won’t let it happen. Hoping someone in the know can shed some light

thank you so much man for this one, i recently did a fresh install of my windows and the processing IDE bugs out when activating android mode

this helped alot…