Android emulator

I tried to Run in Emulator this super- simple code in Processing’s Android mode:

void setup() {
  size(640, 360);

void draw() {
  circle(width/2, height/2, 32);

Howewer, the console shows these two messages:

EmulatorController: Emulator is not available.
Error while starting the Emulator. (NOT_RUNNING)

I regularly installed Android Studio and its Emulators with all the possible SDKs I was able to think to, without success. I also noted that while installing the Android mode on Processing i was not asked to download the system image needed by the emulator to work as written in Processing for Android.

I also googled the error messages but found nothing interesting - can you please point me to any procedure that could help?

read this

and this

you can use your android it self as emulator with out the

Android Studio emulator and with out installing Android Studio

if you want to run Android Studio then enable the emulator for processing android mode you have to setup HAXM first and it is too slow when you emulate sketch

avoid Android Studio install the sdk direct you got faster results

1 Like

Hello jafal,
unfortunately I was not able to make your stuff run.
Would you be so kind to post a step-by-step guide?
Thank you.


1 / uninstall every thing clean your temp folder
i mean remove processing from your pc

2/ make restart to your pc before the new installation
install processing once again

3/ download this file

4/ unzipped it to any path and folder lets say :


then select this path when you start processing android mode
D:\android\android\sdk when processing ask for sdk destination
that is all

Hi jafal,
I’ll give it a try.
What’s the difference between the file you point to and the Android SDK installed from Processing?

the difference is that the file i pointed to is that it has the correct version of sdk tools which works with Processing


Android Studio may not has the correct version then processing android mode wont work, but if you install sdk tools for Android Studio which is same version to the i file i told you about for sure it is going to work

even with out or with the Android Studio emulator

PR #639 by @AdityaRana can resolve the issue.
Probably, the issue will be fixed in the next release of the Processing for Android.

1 Like

I’m a little late to the party, but this doesn’t seem to work for me. Instead, I get an error:

The Android SDK could not be loaded.
The Android Mode will be disabled.

I reinstalled everything and parsed in my folder path at: C:\Users\mattz\Documents\Processing\android\sdk.
Still no dice. If you have any other solutions please give me them!

@Mattyjak check if this versions match your folder


here is my folder location

The thing is processing will not even ‘boot’ off of the SDK file path I give it.
I’m using the .zip file you provided but I’m not sure if that’s really the issue.

i am using the same file it is working try to move the folder to D drive i am using win7 64 bit

I realized processing was throwing another error:
Processing found an Android SDK, but is not valid. It could be missing some files, or might not be including the required platform for API 29. If a valid SDK is available in a different location, click "Locate SDK path" to select it, or "Download SDK" to let Processing download the SDK automatically.
It could be that I either downloaded the wrong file or it lost certain files due to the unzipping process. I’m not too sure, but I’ll still try to move it to the D drive.


I’m also using win10 64bit

re-download the file once again and disable the antivirus application while downloading and while unzip


Have you been able to get your Processing emulator to work? Using a Mac I got the same error message that you posted but now have the emulator working and have successfully run your demo code. The first step was to be certain that the emulator is listed in Android Studio at the top of the IDE under the Devices menu. If the emulator that you want to use is not listed then use AndroidStudio/Tools/AVD Manager to create the corresponding Virtual Device. Then I went into AndroidStudio/Tools/SDK Manager/SDK Tools and made certain that the latest update for the Android Emulator was installed (30.6.5). Click on the minus sign at the left to change it to a check mark to install it. You may have to reinstall Processing/Tools/Add Tool/Modes/Android Mode after updating. From there it worked as expected. There are also Terminal commands that you can use to run the emulator, but that is more complicated and I won’t list it here unless you want to try it.

1 Like

Hi @svan,
unfortunately Android Studio is stuck on “Loading Devices…”
I’m using 4.2 version

unfortunately Android Studio is stuck on “Loading Devices…”

Go to Tools/AVD Manager and see if you have any Virtual Devices listed there. You should have at least one called ‘processing-phone’.

Well, there isn’t.
Seems strange, doesn’t it?

I was able to get to the AVD Manager but maybe I was on Windows or it was a previous version. I can’t find it anymore.

I also tried enabling “Launch in a tool window” in Android Studio > Preferences > Emulator with no success