Android emulator

Hello,
I tried to Run in Emulator this super- simple code in Processing’s Android mode:

void setup() {
  size(640, 360);
  background(0);
}

void draw() {
  noStroke();
  fill(255);
  circle(width/2, height/2, 32);
}

Howewer, the console shows these two messages:

EmulatorController: Emulator is not available.
Error while starting the Emulator. (NOT_RUNNING)

I regularly installed Android Studio and its Emulators with all the possible SDKs I was able to think to, without success. I also noted that while installing the Android mode on Processing i was not asked to download the system image needed by the emulator to work as written in Processing for Android.

I also googled the error messages but found nothing interesting - can you please point me to any procedure that could help?

read this

and this

you can use your android it self as emulator with out the

Android Studio emulator and with out installing Android Studio

if you want to run Android Studio then enable the emulator for processing android mode you have to setup HAXM first and it is too slow when you emulate sketch

avoid Android Studio install the sdk direct you got faster results

1 Like

Hello jafal,
unfortunately I was not able to make your stuff run.
Would you be so kind to post a step-by-step guide?
Thank you.

@Th3cG

hi
1 / uninstall every thing clean your temp folder
i mean remove processing from your pc

2/ make restart to your pc before the new installation
install processing once again

3/ download this file

4/ unzipped it to any path and folder lets say :

D:\android\android\sdk

then select this path when you start processing android mode
D:\android\android\sdk when processing ask for sdk destination
that is all

Hi jafal,
I’ll give it a try.
What’s the difference between the file you point to and the Android SDK installed from Processing?

the difference is that the file i pointed to is that it has the correct version of sdk tools which works with Processing

@Th3cG

Android Studio may not has the correct version then processing android mode wont work, but if you install sdk tools for Android Studio which is same version to the i file i told you about for sure it is going to work

even with out or with the Android Studio emulator

PR #639 by @AdityaRana can resolve the issue.
Probably, the issue will be fixed in the next release of the Processing for Android.

1 Like

I’m a little late to the party, but this doesn’t seem to work for me. Instead, I get an error:

The Android SDK could not be loaded.
The Android Mode will be disabled.

I reinstalled everything and parsed in my folder path at: C:\Users\mattz\Documents\Processing\android\sdk.
Still no dice. If you have any other solutions please give me them!
-Matty

@Mattyjak check if this versions match your folder

C:\Users\mattz\Documents\Processing\android\sdk


.
here is my folder location
D:\android\android\sdk

The thing is processing will not even ‘boot’ off of the SDK file path I give it.
I’m using the .zip file you provided but I’m not sure if that’s really the issue.

@Mattyjak
i am using the same file it is working try to move the folder to D drive i am using win7 64 bit

Update:
I realized processing was throwing another error:
Processing found an Android SDK, but is not valid. It could be missing some files, or might not be including the required platform for API 29. If a valid SDK is available in a different location, click "Locate SDK path" to select it, or "Download SDK" to let Processing download the SDK automatically.
It could be that I either downloaded the wrong file or it lost certain files due to the unzipping process. I’m not too sure, but I’ll still try to move it to the D drive.

Summary

I’m also using win10 64bit

re-download the file once again and disable the antivirus application while downloading and while unzip