Android emulator

Here’s what I see on my Mac with AndroidStudio 4.2.1

On the toolbar straight across from the Devices menu about the fourth icon from the right edge of the window should be another button which will take you to the AVD Manager. Do you have that icon? If all this fails we’ll use Command-line tools to check for your avd list. Don’t give up; we should be able to get this to work.

Try typing or copy/pasting this line of code into a Terminal window and post the output:

~/Library/Android/sdk/emulator/emulator -list-avds

on MacOS
Going on Help > Find Action and typing AVD I found the manager
Noting that processing-phone was missing I clicked on Download on the right
Then launched Processing, switched to Android Mode and…


that worked!
I just have to fix some errors in my app but the Emulator is ok.
@svan thank you!

Out of curiosity what is the build time with the emulator as opposed to a real device?

I made two launches with the Emulator, in the first the time was 12s while in the second was 8s
On a real device I had 6s and 5s

1 Like

Sorry for the late response (I had finals due). I couldn’t get it to work. I got very frustrated after the emulator started working, but processing couldn’t detect that it was open and loaded. I essentially gave up to continue working on my game in the meantime.

In my case on Windows I wasn’t able to follow the path described earlier, as installing Android Studio ain’t show up processing-phone in AVD.
I also tried to use the Android > SDK updater on Processing. It founds 1 update available as shown here:

but throws the following error message:

java.lang.NoClassDefFoundError: org/apache/commons/compress/archivers/zip/ZipFile

Then I uninstalled Processing and reinstalled it again. Sounds odd, but after installing Android Mode, SDK version 29 and Intel XAMH I still couldn’t see the Emulator. However, I had to quit the computer due to external circumstances and reboot it in MacOs. Then after a while I switched off the computer. After a few hours I rebooted it in Windows and the magic happened… the Emulator is currently running.

@Mattyjak hope this can help you - and that your finals were fine :slight_smile:

1 Like