3D in Raspberry PI4

I have installed Processing 3.5.3 on Raspberry PI4. 3.5.3, because there is a specific version for ARM. When I used programs with P3D (3D) an error code is send on black window. Same Processing version on Windows 11, with sames parametres, programs works correctly.
error message : failed to add service- already in use ? Could not run the sketch ( Target VM failed to initialize). Any way to solve my problem ? Thank you

If I remember correctly following “experimental graphics” in this doc might help

@Eta14 not all P3D sketches will work on RaspberryPI4 but many will. The original support for processing was for the RaspberryPI3 Getting Started - Processing for Pi and most of the technical information in the link @micaut supplied is totally irrelevant to RaspberryPI4 but that’s the latest official support. I’ve successfully installed an alpha version of processing4 on ManjaroArm see here Processing in style with Java 11 - #40 by monkstone. NB: The official alpha3 version does not work!!! In principle there’s no reason why it won’t also work on RaspberryPI OS, because my PiCrate (ruby-processing for RaspberryPI) works on both operating systems.

1 Like

@Eta14 I can get the service in use? message if I use legacy video driver, you need to run raspi-config Advanced Options then A2 Gldriver and enable G2 GL Fake KMS then reboot. VC4 full KMS not available on RaspberryPI4 yet. This only applies to RaspberryPI OS, Manjaro Arm it is enabled by default…

Thank you Martin. I did this operation yesterday. Naoto Hieda have suggested to read a technical documentation, day before. So I modified configuration. Now Processing work correctly in most exemples with P3D. I have solve an other problem, Raspberry PI4 can be connected to 2 screens. Before yesterday, probably after an update or upgrade, only one sreen displayed data. Now the two ones dispay differents images.
Again thank you for your help.

Thank Naoto for suggestion, I read technical documentation. Modification of raspi-config, advanced option, GL driver, set to G2 (Fake KMS). From severals days, I had lost the second sreen, now both ones are working. Thank you for your help.

1 Like