Processing performance always worse on Pi 4

Hi,

I’m trying to use a pi to make a graphical clock with processing.

On the old pre-made OS image that had processing 3.4 preinstalled, simple sketches would run at a perfect 60 fps. That image runs the older Raspian that won’t run on a Pi 4.

With every other combination of versions, I get choppy frame rates even when just rendering a single rotating cube. I’ve tried:

pi 4 with 32 bit Raspian, processing 3.5.3
pi 4 with 32 bit Raspian, processing 4.0b7
pi 4 with 64 bit Raspian, processing 3.5.3
pi 4 with 64 bit Raspian, processing 4.0b7
pi 4 with 32 bit Raspian Lite, with a super minimal desktop

also, pi 3 with more recent Raspian, manually installed processing 3.5.3

None of them run as well as the dedicated image did. However, I’m doing some GLSL stuff that won’t compile on that version, and of course I’d rather have the superior power of the pi 4!

I’m guessing this is a driver / OpenGL thing, seems to be GPU bound as the CPU isn’t being taxed at all with my tests.

Any help much appreciated!

Hello. Unfortunately I can’t help you to solve this issue, but I’d be extremely grateful if I could hear how you managed to install processing 3.5.3 on a pi 4 with 32 bit Raspian.

In the official page, processing 3.5.3 appears to be available only for Linux 64 bit. I’ve also tried to look for a 32 bit version on the Processing Foundation’s Github bit didn’t find such a release.

Thank you. And I hope you will receive the help you need!

Unfortunately I can’t help solve your either I’m afraid. I misspoke, I didn’t actually try that particular config.