Why Isn't My Contributed Library Showing?

Hello, I’ve been wracking my brain with this issue. I’m trying to install the ‘SimpleOpenNI’ in Processing and I think I’ve followed the steps correctly? But I’m also not entirely sure and the error I keep getting says that the library hasn’t been installed correctly.

I am using Processing version 3.5.4, and installed the most recent library I could find which is for 3.5.3. I’m also using OSX Monterery and checked Processing 4 to see if it would work there but I’ve had no luck

Here is how it is laid out in the ‘libraries’ folder, I’ve even gone through the Preferences in Processing to make sure it’s the right folder:

Would really appreciate some help on this please, I’ve spent over an hour trying to sort it. Thanks in advance for any advice!

It’s impossible from the pictures to check the file structure so they don’t help. The following picture shows the structure for the G4P library and demonstrates the important features.

  1. Processing 3 folder is where I store my sketches
  2. the libraries folder holds all the 3rd party contributed libraries
  3. NOTICE that the library folder (G4P)has the same name as the library jar file (G4P.jar) including text case - this is important
  4. Inside this there is a sub folder called library and inside that the library jar file.

Click on the image to enlarge it -

1 Like

Thank you so much for replying! And sorry about that, I thought the bit at the bottom would be helpful.

I’ve tried doing this and here is the outcome, but it’s still not working - do you see where this is going wrong at all? I just copied and pasted the downloaded library in to ‘libraries’, but it looks like it has a duplicate folder inside it? (4th column). I moved it to the bin but then it lost the rest of the stuff (columns 5 and 6). I really appreciate the help you’ve already given, thank you! Sorry to keep asking questions

To see if the duplicate folder was an issue, I made a new folder without it and tried it that way, but it’s still not working. I’ve double checked Processing’s Preferences to make sure I’m using the right ‘libraries’ folder (for some reason I have multiple, maybe because I have 2 versions of Processing downloaded?). I’m so sorry if the issue is blatant, it happens whenever I try to use a contributed library so I’m assuming I’m doing something very wrong here

Two things here.
Your latest file structure is still wrong it should look something like this

In other words
Sketch_folder > libraries > lib_name > library > lib_name.jar

Do you have problems with libraries installed with the Contributions manager - if not then you are doing something wrong.


Amazing, thank you so much! Got rid of the images etc but I can work around that.

For anyone reading this for help, I created a new folder called ‘SimpleOpenNI’, and pasted the ‘documentation’ ’ examples’ etc folders inside and it worked! It looks exactly like the photo quark gave :slight_smile: