Error during download and install of <library.name>

Hi,

I am a beginner and I am starting small - like - how to install a library. I run Processing 3.5.3 and using Menu - Import Library - Add Library. I am getting the following error: Error during download and install of … and here you can add any library name. I tried several and libraries and Ani, ColorScheme and ComputationalGeometry loaded but others like Combinatorics, Free Transform, GenerativeDesign, Image processing algorithms, ImageLoader, etc will not load.

What i am doing wrong?

I am mostly interested in GenerativeDesign (i got the book for it so of course i want to try their examples and see if i can understand them) and ImageLoader.

I also search the topics for this error - but it seems i could not find it.

Thanks,
Monica

1 Like

if you talk about this
https://processing.org/reference/libraries/
i use the contribution manager

/Tools / Add Tool / Libraries /

in some cases it needs to restart the PDE.

but then can find in examples the related for this new installed library,
best way to start,
play/test all
save the one you like “save as” into your sketchbook
and start from there.

if you not know processing, and not know a library
it is nearly impossible to start from a empty page with

import this_new_library.*;

again, have fun with the examples…

and also find

/ Help / Library Reference / …

after you installed one.

1 Like

Hi,

Yes, i tried to restart Processing. But for the GenerativeDesign library for example i have sample code and the book, so if i can install this library, theoretically i should be able to run the sample code. From there i can change params and see how the result changes. And so, even if maybe it is not very conventional - i can learn more about processing.

So, the problem is that i cannot install some libraries through the software menu. I am getting this error:

Error during download and install of GenerativeDesign

And i am getting same error on other libraries as well. And very few actually install, so i am not sure what is the difference from one library to the next.

Any help is very much appreciated.

Happy Thanksgiving for those how are celebrating,
Monica

now we might need to give more specific information:
? here ? means
-1- windows 10 / 64 bit /
-2- processing 3.5.3 /64 bit /

as i never used that one:
-3- find that lib in the Contribution Manager list, install it, try example

so here it works well.


as i am not a expert i can not tell if / where there is a
install log file
you could check deeper on the problem.
i not found something like a log/err at
c:\Users\ < User > \AppData\Roaming\Processing\console
( that is the place where errors from running a sketch can be found )


so,
? download problems
? system problems


if you not have win 10 that might not be of help,
AND you might want have help from someone who have same
environment like you?


could you check in the library path if there is anything from that download?

and if, better clear it out??

1 Like

Hi,

Thanks so much. I will go in more details over your email but i have windows 10, and i did install Processing 64 bit version 3.5.3. So i should be fine. I also tried to run Processing as an administrator if that was a problem, but unfortunately with the same error result.

Also there is nothing installed for GenerativeDesign in the library path.

So i need to dig more. What is puzzling is that lots of other libraries give the same error when i try to install. It is almost like the library starts installing and after 1 or 2 seconds gives up and gives the error. Very strange.

Thanks,
Monica

Hi again,

Finally i solved the problem. It was my system that proved troublesome. For whatever reason (i suppose security installed on my system by IT) i could not install libraries unless i was signed from the beginning as an administrator, not only run Processing as an administrator. Also i had to change the path in preferences to a drive location different than C.

Thanks for all the help,
Monica

2 Likes